php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76445 Conditional jump or move depends on uninitialised value
Submitted: 2018-06-11 09:50 UTC Modified: 2018-06-11 10:45 UTC
From: spam2 at rhsoft dot net Assigned:
Status: Not a bug Package: opcache
PHP Version: master-Git-2018-06-11 (Git) OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: spam2 at rhsoft dot net
New email:
PHP Version: OS:

 

 [2018-06-11 09:50 UTC] spam2 at rhsoft dot net
Description:
------------
there are several places

==194503== Conditional jump or move depends on uninitialised value(s)
==194503==    at 0x6EB6AF6: zend_string_equal_val (zend_string.c:405)
==194503==    by 0x6E8C3EC: zend_string_equal_content (zend_string.h:310)
==194503==    by 0x6E8E5D0: zend_hash_find_bucket (zend_hash.c:576)
==194503==    by 0x6E936EF: zend_hash_find (zend_hash.c:2071)
==194503==    by 0x6E5F680: zend_get_constant (zend_constants.c:280)
==194503==    by 0x6E36065: zend_ini_get_constant (zend_ini_parser.y:152)
==194503==    by 0x6E37554: ini_parse (zend_ini_parser.y:416)
==194503==    by 0x6E364DD: zend_parse_ini_file (zend_ini_parser.y:238)
==194503==    by 0x6DF2A51: php_init_config (php_ini.c:632)
==194503==    by 0x6DE91BB: php_module_startup (main.c:2109)
==194503==    by 0x6F5342D: php_apache2_startup (sapi_apache2.c:374)
==194503==    by 0x6F53622: php_apache_server_startup (sapi_apache2.c:487)

==194503== Conditional jump or move depends on uninitialised value(s)
==194503==    at 0x6EB6AF6: zend_string_equal_val (zend_string.c:405)
==194503==    by 0x8E0DF0A: zend_string_equal_content (zend_string.h:310)
==194503==    by 0x8E0ED4A: accel_new_interned_string (ZendAccelerator.c:469)
==194503==    by 0x8E0F889: accel_copy_permanent_strings (ZendAccelerator.c:646)
==194503==    by 0x8E10004: accel_use_shm_interned_strings (ZendAccelerator.c:746)
==194503==    by 0x6EB6A4E: zend_interned_strings_switch_storage (zend_string.c:316)
==194503==    by 0x6DE964A: php_module_startup (main.c:2273)
==194503==    by 0x6F5342D: php_apache2_startup (sapi_apache2.c:374)
==194503==    by 0x6F53622: php_apache_server_startup (sapi_apache2.c:487)
==194503==    by 0x1791FB: ap_run_post_config (in /usr/sbin/httpd)
==194503==    by 0x14A3D0: main (in /usr/sbin/httpd)

==194503== Conditional jump or move depends on uninitialised value(s)
==194503==    at 0x6EB6AF6: zend_string_equal_val (zend_string.c:405)
==194503==    by 0x8E0DF0A: zend_string_equal_content (zend_string.h:310)
==194503==    by 0x8E0ED4A: accel_new_interned_string (ZendAccelerator.c:469)
==194503==    by 0x8E1E371: zend_persist_zval_calc (zend_persist_calc.c:122)
==194503==    by 0x8E1E757: zend_persist_op_array_calc_ex (zend_persist_calc.c:179)
==194503==    by 0x8E1F362: zend_persist_op_array_calc (zend_persist_calc.c:260)
==194503==    by 0x8E1E09F: zend_hash_persist_calc (zend_persist_calc.c:86)
==194503==    by 0x8E20D8E: zend_accel_script_persist_calc (zend_persist_calc.c:427)
==194503==    by 0x8E118DE: cache_script_in_shared_memory (ZendAccelerator.c:1481)
==194503==    by 0x8E12ECB: persistent_compile_file (ZendAccelerator.c:2093)
==194503==    by 0x6EDEB84: zend_include_or_eval (zend_execute.c:3115)
==194503==    by 0x6EE65AE: ZEND_INCLUDE_OR_EVAL_SPEC_CONST_HANDLER (zend_vm_execute.h:3301)

==194503== Conditional jump or move depends on uninitialised value(s)
==194503==    at 0x6EB6AF6: zend_string_equal_val (zend_string.c:405)
==194503==    by 0x8E0DF0A: zend_string_equal_content (zend_string.h:310)
==194503==    by 0x8E10AF7: do_validate_timestamps (ZendAccelerator.c:1051)
==194503==    by 0x8E10C9F: validate_timestamp_and_record (ZendAccelerator.c:1094)
==194503==    by 0x8E12BDD: persistent_compile_file (ZendAccelerator.c:2018)
==194503==    by 0x6E2214C: compile_filename (zend_language_scanner.l:662)
==194503==    by 0x6EDECAE: zend_include_or_eval (zend_execute.c:3145)
==194503==    by 0x6EE65AE: ZEND_INCLUDE_OR_EVAL_SPEC_CONST_HANDLER (zend_vm_execute.h:3301)
==194503==    by 0x6F4C3D2: execute_ex (zend_vm_execute.h:54789)
==194503==    by 0x6F5158A: zend_execute (zend_vm_execute.h:59895)
==194503==    by 0x6E7B517: zend_execute_scripts (zend.c:1564)
==194503==    by 0x6DE9AFF: php_execute_script (main.c:2467)

==194503== Conditional jump or move depends on uninitialised value(s)
==194503==    at 0x6EB6AF6: zend_string_equal_val (zend_string.c:405)
==194503==    by 0x6E69D2F: zend_string_equal_content (zend_string.h:310)
==194503==    by 0x6E69D6E: zend_string_equals (zend_string.h:315)
==194503==    by 0x6E740DF: zend_is_identical (zend_operators.c:2201)
==194503==    by 0x6ED64E8: fast_is_not_identical_function (zend_operators.h:797)
==194503==    by 0x6F401E9: ZEND_IS_NOT_IDENTICAL_SPEC_CV_VAR_HANDLER (zend_vm_execute.h:44854)
==194503==    by 0x6F50ACD: execute_ex (zend_vm_execute.h:59227)
==194503==    by 0x6F5158A: zend_execute (zend_vm_execute.h:59895)
==194503==    by 0x6E7B517: zend_execute_scripts (zend.c:1564)
==194503==    by 0x6DE9AFF: php_execute_script (main.c:2467)
==194503==    by 0x6F540F7: php_handler (sapi_apache2.c:701)
==194503==    by 0x1790CD: ap_run_handler (in /usr/sbin/httpd)

Test script:
---------------
not possible, it's running the profile-guided-optimization environment with a debug-enabled binary because of that below which would have been the test suite before the "spidering" and crashed in a optimized build

* OK: cl_api->misc->test(0.241)
 * OK: cl_api->mobile_detect->test(0.001)
 * OK: cl_api->navigation_base_internal->test(0.026)
zend_mm_heap corrupted


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-11 10:12 UTC] nikic@php.net
-Status: Open +Status: Feedback
 [2018-06-11 10:12 UTC] nikic@php.net
This is expected. Please either compile with valgrind support (requires valgrind headers to be installed) or suppress these warnings.
 [2018-06-11 10:30 UTC] spam2 at rhsoft dot net
ok, then close this one - the problem which leaded to make a debug-build is better analyzed at https://bugs.php.net/bug.php?id=76446
 [2018-06-11 10:45 UTC] daverandom@php.net
-Status: Feedback +Status: Not a bug
 [2018-06-11 10:45 UTC] daverandom@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 20:03:34 2021 UTC