php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7643 APXS compile fails with "not a DSO"
Submitted: 2000-11-05 04:27 UTC Modified: 2003-01-28 22:41 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: marvin_lam at agilent dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.0.3pl1 OS: HP-UX 10.20
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marvin_lam at agilent dot com
New email:
PHP Version: OS:

 

 [2000-11-05 04:27 UTC] marvin_lam at agilent dot com
        An error will be produced:
        /path/to/apxs -i -a -n php4 libs/libphp4.sl
        apxs:Error: file libs/libphp4.sl is not a DSO
        make[1]: *** [install-sapi] Error 1
        make[1]: Leaving directory `/wes/build/apache/php-4.0.1pl2'
        make: *** [install-recursive] Error 1

It seems that apxs wants the shared library to be named
        libphp4.so, not libphp4.sl.  Do the following:
        # cp libs/libphp4.sl libs/libphp4.so
        # /path/to/bin/apxs -i -a -n php4 libs/libphp4.so

Is there any way the install scripts can be updated for this on HPUX platform?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-02 09:06 UTC] sniper@php.net
Please try PHP 4.0.4 as this should be fixed.

--Jani
 [2001-01-05 23:23 UTC] sniper@php.net
In duplicate bug report #8518 was mentioned this is still happening with 4.0.4

--Jani
 [2001-05-23 06:07 UTC] sniper@php.net
As the Apache is now at version 1.3.20, maybe they have 
fixed this in it? Please try it out.
Also, PHP 4.0.5 was released a while ago.

Anyways, this is not PHP bug.

--Jani

 [2002-03-29 16:29 UTC] vlima at csc dot com
I am still having the same problems. Here are  my versions of software:

  binutils                      2.11.2         binutils
  bison                         1.34           bison
  flex                          2.5.4a         flex
  gcc                           3.0.1          gcc
  libiconv                      1.7            libiconv
  libpcap                       0.6.2          libpcap
  make                          3.79.1         make
  apache                        1.3.23         apache
  mod_ssl                       2.8.7          mod_ssl
  openssl                       0.9.6c         openssl
  mysql                         3.23.39        mysql
  php                           4.1.2          php


Configure works without a problem. Here is what I am doing for configure:

./configure --prefix=/opt/php --enable-track-vars --with-apxs=/opt/apache/bin/apxs --enable-libgcc --with-mysql=/opt/mysql


"make" works except I get the following messages:

<<<<---START---->>>>
        /bin/sh /opt/patches/php-4.1.2/libtool --silent --mode=link gcc  -I. -I/opt/patches/php-4.1.2/ -I/opt/patches/php-4.1.2/main -I/opt/patches/php-4.1.2 -I/opt/apache/include -I/opt/patches/php-4.1.2/Zend -I/opt/mysql/include -I/opt/patches/php-4.1.2/ext/xml/expat  -DHPUX11 -DMOD_SSL=208107 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I/opt/patches/php-4.1.2/TSRM -g -O2 -prefer-pic   -o libphp4.la -rpath /opt/patches/php-4.1.2/libs -avoid-version -L/opt/gcc/lib/gcc-lib/hppa2.0n-hp-hpux11.00/3.0.1 -L/opt/mysql/lib  -R /opt/gcc/lib/gcc-lib/hppa2.0n-hp-hpux11.00/3.0.1 -R /opt/mysql/lib stub.lo  Zend/libZend.la  sapi/apache/libsapi.la  main/libmain.la  regex/libregex.la  ext/mysql/libmysql.la ext/pcre/libpcre.la ext/posix/libposix.la ext/session/libsession.la ext/standard/libstandard.la ext/xml/libxml.la  TSRM/libtsrm.la -lpam -lmysqlclient -lcrypt -lm -lnsl -lgcc -lcrypt

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lmysqlclient.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lgcc.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.
Making all in pear

<<<<---END---->>>>>

Then when attempting to do "make install", here's the real kicker:


<<<---START-->>>>

Making install in Zend
Making install in main
Making install in ext
Making install in mysql
Making install in pcre
Making install in pcrelib
Making install in posix
Making install in session
Making install in standard
Making install in xml
Making install in expat
Making install in sapi
Making install in apache
        /bin/sh /opt/patches/php-4.1.2/libtool --silent --mode=link gcc  -I. -I/opt/patches/php-4.1.2/sapi/apache -I/opt/patches/php-4.1.2/main -I/opt/patches/php-4.1.2 -I/opt/apache/include -I/opt/patches/php-4.1.2/Zend -I/opt/mysql/include -I/opt/patches/php-4.1.2/ext/xml/expat  -DHPUX11 -DMOD_SSL=208107 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I/opt/patches/php-4.1.2/TSRM -g -O2 -prefer-pic   -o libsapi.la  sapi_apache.lo mod_php4.lo php_apache.lo
Making install in TSRM
        /bin/sh ../libtool --silent --mode=link gcc  -g -O2 -prefer-pic  -o libtsrm.la   TSRM.lo tsrm_strtok_r.lo tsrm_virtual_cwd.lo
Making install in regex
Making install in .
        /bin/sh /opt/patches/php-4.1.2/libtool --silent --mode=link gcc  -I. -I/opt/patches/php-4.1.2/ -I/opt/patches/php-4.1.2/main -I/opt/patches/php-4.1.2 -I/opt/apache/include -I/opt/patches/php-4.1.2/Zend -I/opt/mysql/include -I/opt/patches/php-4.1.2/ext/xml/expat  -DHPUX11 -DMOD_SSL=208107 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I/opt/patches/php-4.1.2/TSRM -g -O2 -prefer-pic   -o libphp4.la -rpath /opt/patches/php-4.1.2/libs -avoid-version -L/opt/gcc/lib/gcc-lib/hppa2.0n-hp-hpux11.00/3.0.1 -L/opt/mysql/lib  -R /opt/gcc/lib/gcc-lib/hppa2.0n-hp-hpux11.00/3.0.1 -R /opt/mysql/lib stub.lo  Zend/libZend.la  sapi/apache/libsapi.la  main/libmain.la  regex/libregex.la  ext/mysql/libmysql.la ext/pcre/libpcre.la ext/posix/libposix.la ext/session/libsession.la ext/standard/libstandard.la ext/xml/libxml.la  TSRM/libtsrm.la -lpam -lmysqlclient -lcrypt -lm -lnsl -lgcc -lcrypt

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lmysqlclient.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lgcc.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypt.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.
        /opt/patches/php-4.1.2/build/shtool mkdir -p "/opt/apache/libexec" && /opt/apache/bin/apxs -S LIBEXECDIR="/opt/apache/libexec" -i -a -n php4 libs/libphp4.sl
apxs:Error: file libs/libphp4.sl is not a DSO
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.

<<<---END---->>>>


I've attempted renaming the libs/libphp4.sl to .so and no luck.  Can anyone help out?

Thanks,
Vinnie
 [2002-04-12 06:13 UTC] cn at pinck dot ch
Read that:

http://aspn.activestate.com/ASPN/Mail/Message/php-install/937938

In fact, what you have to do after "make install" is

- rename <php_dir>/libs/libphp4.sl to libphp4.so

- and run the apxs tooll manually:

/opt/apache/bin/axps -i -a -n php4 <php_dir/libs/libphp.so

That should do it ...
 [2002-04-13 16:50 UTC] markonen@php.net
So, I guess the question now is that should we continue to 
be "clever" and install apache DSOs with the platform-
specific SHLIB_SUFFIX_NAME or just use .so which is what 
Apache expects. I'm using .so for the Mac OS X build, even 
though .bundle would be the native suffix for the object 
type we're producing.

I.e. it's now time to decide whether this is an Apache or a 
PHP bug.
 [2003-01-02 18:16 UTC] nicos@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2003-01-02 18:20 UTC] nicos@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2003-01-17 22:08 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-01-28 16:10 UTC] marvin_lam at agilent dot com
We were still experiencing it even with the newer versions of PHP.  However, this is no longer an issue for us because of the following two reasons:
(1) We no longer support HP-UX 10.20 systems (since HP will no longer support these as of June 2003)
and
(2) HP now has a [free] PRE-COMPILED software depot available at software.hp.com with PHP compiled into Apache.

Thank you for your time in looking into this!
 [2003-01-28 22:41 UTC] sniper@php.net
Let's keep this closed. There are other open reports about
this same issue so no need for yet another one. :)

And thank you for the information about precompiled apache+php. 

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 10:01:26 2020 UTC