php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76426 PDO_IBM-1.3.5 Build fail on windows [ php 7.0.30 ,VS 2015 ]
Submitted: 2018-06-07 16:20 UTC Modified: 2018-06-07 16:37 UTC
From: ronyan at outlook dot com Assigned: cmb (profile)
Status: Duplicate Package: PDO_IBM (PECL)
PHP Version: 7.0.30 OS: Windows Server 2012
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ronyan at outlook dot com
New email:
PHP Version: OS:

 

 [2018-06-07 16:20 UTC] ronyan at outlook dot com
Description:
------------
PHP : 7.0.30
Vistual Studio: VS2015 x64 Native Tools Command Prompt
PDO_IBM-1.3.5
ibm_data_server_driver_package_win64_v11.1





Test script:
---------------
configure --disable-zts --enable-pdo --with-pdo-ibm="C:\Program Files\IBM\IBM DATA SERVER DRIVER\lib",shared

Expected result:
----------------
Build complete with success.

Actual result:
--------------
Creating library E:\php\php-sdk\phpdev\vc14\x64\php-7.0.19-src\x64\Release\php_pdo_ibm.lib and object E:\php\php-sdk\phpdev\vc14\x64\php-7.0.19-src\x64\Release\php_pdo_ibm.exp
ibm_driver.obj : error LNK2019: unresolved external symbol Z_STRVAL_PP referenced in function dbh_connect
E:\php\php-sdk\phpdev\vc14\x64\php-7.0.19-src\x64\Release\php_pdo_ibm.dll : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 14.0
\VC\BIN\amd64\link.exe"' : return code '0x460'

Patches

ibm_driver.c (last revision 2018-06-07 16:20 UTC by ronyan at outlook dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-07 16:37 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: Compile Failure +Package: PDO_IBM -Assigned To: +Assigned To: cmb
 [2018-06-07 16:37 UTC] cmb@php.net
Duplicate of bug #74114.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 14 15:01:23 2019 UTC