php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76332 Cannot find php_pdo_driver.h.
Submitted: 2018-05-11 18:05 UTC Modified: 2018-05-11 23:14 UTC
From: call dot of dot shad at gmail dot com Assigned:
Status: Not a bug Package: PDO OCI
PHP Version: 5.6.36 OS: Ubuntu 16.04 LTS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: call dot of dot shad at gmail dot com
New email:
PHP Version: OS:

 

 [2018-05-11 18:05 UTC] call dot of dot shad at gmail dot com
Description:
------------
I'm trying recreate my environment in ubuntu and I need pdo_oci for connect to oracle db. After phpize, I run ./configure --with-pdo-oci=instantclient,/usr,11.2 but it finishes in these:

checking for oci.h... /usr/include/oracle/11.2/client64
checking for OCIEnvCreate in -lclntsh... yes
checking for OCIEnvNlsCreate in -lclntsh... yes
checking for OCILobIsTemporary in -lclntsh... yes
checking for OCICollAssign in -lclntsh... yes
checking for OCIStmtFetch2 in -lclntsh... yes
checking for PDO includes... checking for PDO includes... 
configure: error: Cannot find php_pdo_driver.h.

Is there a fix to this?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-11 18:32 UTC] spam2 at rhsoft dot net
likely devel packages not installed - why don't you at least just provide the installed php packages when you confuse a bug tracker with stackoverflow
 [2018-05-11 20:10 UTC] call dot of dot shad at gmail dot com
Sorry for register this like a stackoverflow question. I would edit it, but the temp password not matched.
 
-the installed packages are:
 php5.6 php5.6-common libapache2-mod-php5.6 php5.6-cli php5.6-dev php-pear

-The problem seems be in the configure file of pdo_oci sources as the dependency php_pdo_driver.h isn't in the pdo_oci directory. It is in pdo directory, so my guess is that .configure file just needs be fixed to find the correct path. Or the includes inside each related .h files.

-I did a workaround compiling and installing pdo before pdo_oci so the dependency php_pdo_driver.h was found. I don't know if it's a correct way, but solved my case. I need confirmation.
 [2018-05-11 20:26 UTC] spam2 at rhsoft dot net
I bet Debian has a separated pdo-dev package because it makes no sense to install the header files by default - that's why devel packages exists
 [2018-05-11 23:14 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-05-11 23:14 UTC] requinix@php.net
> I did a workaround compiling and installing pdo before pdo_oci
That isn't a workaround - it's what you should do. Can't compile something if you don't have the dependencies.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 18 11:01:30 2019 UTC