php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76228 Unsupported Twofish algorithm due to mcrypt deprecation
Submitted: 2018-04-17 11:09 UTC Modified: 2018-04-17 11:20 UTC
From: mageia at mokraemer dot de Assigned:
Status: Not a bug Package: mcrypt related
PHP Version: 7.2.4 OS: Mageia Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mageia at mokraemer dot de
New email:
PHP Version: OS:

 

 [2018-04-17 11:09 UTC] mageia at mokraemer dot de
Description:
------------
Due to deprecation of mcrypt library, the newer Twocrypt algorithm is unsupported. Please keep this in mind before dropping mcrypt support!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-17 11:20 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: OpenSSL related +Package: mcrypt related
 [2018-04-17 11:20 UTC] requinix@php.net
mcrypt is gone because it's not maintained, and for something as important as cryptography that's not a good thing.
Still need Twofish? Then keep using mcrypt - at your own risk.

Or find another solution. https://www.google.com/search?q=php+twofish+-mcrypt
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 09:03:37 2021 UTC