php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76209 Unexpected behaviour for output_add_rewrite_var treating links to url fragments
Submitted: 2018-04-11 14:35 UTC Modified: 2018-04-11 14:39 UTC
From: michele dot scaramal at sella dot it Assigned:
Status: Duplicate Package: Output Control
PHP Version: 7.2.4 OS: windows, apache 2.4.33 win 64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michele dot scaramal at sella dot it
New email:
PHP Version: OS:

 

 [2018-04-11 14:35 UTC] michele dot scaramal at sella dot it
Description:
------------
The function output_add_rewrite_var is not treating correctly links to fragments on the same html document.


url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"

Test script:
---------------
ob_start();
output_add_rewrite_var('var', 'value');
echo "<a href='#anchor'>anchor link</a>";
ob_end_flush();
die;




Expected result:
----------------
Result 7.1.16: 
<a href='#anchor'>anchor link</a>Array

Actual result:
--------------
Result 7.2.4: 
<a href='#anchor/?var=value'>anchor link</a>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-04-11 14:39 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2018-04-11 14:39 UTC] requinix@php.net
Duplicate of bug #74892
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 04:03:35 2021 UTC