php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76154 missing php7apache2_4.dll
Submitted: 2018-03-27 14:50 UTC Modified: 2018-03-27 15:03 UTC
From: jerre at xs4all dot nl Assigned: cmb (profile)
Status: Not a bug Package: Apache2 related
PHP Version: 7.2.3 OS: Windows 10
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jerre at xs4all dot nl
New email:
PHP Version: OS:

 

 [2018-03-27 14:50 UTC] jerre at xs4all dot nl
Description:
------------
The https://windows.php.net/downloads/releases/php-7.2.3-nts-Win32-VC15-x64.zip seems to be missing the file php7apache2_4.dll.

Test script:
---------------
download https://windows.php.net/downloads/releases/php-7.2.3-nts-Win32-VC15-x64.zip
and unzip

This might have the same cause/ solution as 
https://bugs.php.net/bug.php?id=69801 but that has been fixed long ago.

The dll is present in the thread-safe version though:
https://windows.php.net/downloads/releases/php-7.2.3-Win32-VC15-x64.zip


Expected result:
----------------
existing php7apache2_4.dll

Actual result:
--------------
missing php7apache2_4.dll

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-27 15:03 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-03-27 15:03 UTC] cmb@php.net
> The dll is present in the thread-safe version though:

Shipping php7apache2_4.dll with the NTS builds wouldn't make
sense, since the Apache module requires ZTS builds, anyway.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 13:06:06 2022 UTC