php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76118 ZEND_ACC_FETCH not defined
Submitted: 2018-03-20 04:11 UTC Modified: 2018-03-20 12:28 UTC
From: Andy_Schmidt at HM-Software dot com Assigned: cmb (profile)
Status: Duplicate Package: PECL (PECL)
PHP Version: 7.2.3 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: Andy_Schmidt at HM-Software dot com
New email:
PHP Version: OS:

 

 [2018-03-20 04:11 UTC] Andy_Schmidt at HM-Software dot com
Description:
------------
UOPZ 5.02 under Windows does not define ZEND_ACC_FETCH.

Test script:
---------------
// Will echo name of undefined constant as string
echo( ZEND_ACC_FETCH );

if ( !defined( 'ZEND_ACC_FETCH' ) )
	define( 'ZEND_ACC_FETCH', PHP_INT_MAX );

// Now will the integer value of previously missing constant
echo( ZEND_ACC_FETCH );


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-20 12:28 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-03-20 12:28 UTC] cmb@php.net
Since the source code repo of UOPZ has its own bug tracker[1], it
seems to be preferable to track issues there.  That should,
however, be reflected on the PECL page of the extension (i.e. the
"Report new bug" URL should be changed).

Anyhow, this ticket is a duplicate of
<https://github.com/krakjoe/uopz/issues/67>.

[1] <https://github.com/krakjoe/uopz/issues>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 18 16:01:24 2021 UTC