php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #761 When compiled in as module, PHP will misreport the termination of httpd process
Submitted: 1998-09-20 00:14 UTC Modified: 1998-11-25 02:03 UTC
From: jeff at wipd dot com Assigned: rasmus (profile)
Status: Closed Package: Performance problem
PHP Version: 3.0.3 OS: Linux 2.0.35
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeff at wipd dot com
New email:
PHP Version: OS:

 

 [1998-09-20 00:14 UTC] jeff at wipd dot com
Basically, all you need to reproduce this is a high-traffic site (few hundreds hits a day is actually all you will NEED), and the PHP module compiled into Apache 1.3.1.

I also have the FrontPage extensions for 1.3.0 installed, but I doubt that that has anything to do with the problem.  Everything else as far as configuration goes is normal.

After a while of web-serving, a few hundred people will hit a .phtml page over and over, and for some reason, the httpd process that serves these pages dies (which is normal, due to keepalive), but what's weird is that it doesn't get reported on Apache's scoreboard.  So if you go to the "status" page of Apache you will see a ton of httpd processes serving PHTML pages, but none of them actually exist on the system.

The way to workaround this is to compile PHP as a cgi-bin binary, other than compiling it as a module.  I have found no problems when running PHP3 in this way, but it would be nice to have it compiled into the web server anyways...

If any of the programmers can figure out a solution to this, I would appreciate it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-11-25 02:03 UTC] rasmus
I don't see how this can be a PHP bug.  Try the latest version of Apache.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 08:01:24 2020 UTC