php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76089 I can show and discover the server side script
Submitted: 2018-03-13 12:22 UTC Modified: 2018-03-13 12:38 UTC
From: gergelymolnarpro at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gergelymolnarpro at gmail dot com
New email:
PHP Version: OS:

 

 [2018-03-13 12:22 UTC] gergelymolnarpro at gmail dot com
Description:
------------
I can show and discover the server side script code with a simple http request at http://php.net
Example: http://php.net/cached.php?f=/index.php
Example2: http://php.net/cached.php?f=/include/prepend.inc


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-13 12:24 UTC] gergelymolnarpro at gmail dot com
If it is closed and fixed, can I report that at hackerone.com?
 [2018-03-13 12:38 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-03-13 12:38 UTC] cmb@php.net
The code is publicly available anyway[1], so there is no bug.

[1] <https://github.com/php/web-php/blob/master/index.php>
    <https://github.com/php/web-php/blob/master/include/prepend.inc>
 [2018-03-13 12:46 UTC] gergelymolnarpro at gmail dot com
Sorry for report that. I thought I found a nice bug...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 23:05:47 2022 UTC