php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76004 PECL Package Upload is broken
Submitted: 2018-02-24 05:23 UTC Modified: 2018-12-06 09:33 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: stanleycheung at google dot com Assigned: petk (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: stanleycheung at google dot com
New email:
PHP Version: OS:

 

 [2018-02-24 05:23 UTC] stanleycheung at google dot com
Description:
------------
Cannot upload any new release for PECL extension. Got an error on screen: "Upload error: The destination directory doesn't exist or is a regular file."

Expected result:
----------------
Able to upload new release

Actual result:
--------------
Got error on screen: "Upload error: The destination directory doesn't exist or is a regular file."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-02-24 10:15 UTC] cmb@php.net
-Package: PECL +Package: Systems problem
 [2018-02-27 21:56 UTC] zaq178miami at gmail dot com
Same here with uploading php-v8
 [2018-12-06 09:33 UTC] petk@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: petk
 [2018-12-06 09:33 UTC] petk@php.net
Hello, thank you for reporting issues. Sorry for bumping old issues but to keep issues in sync this one looks like has been fixed in the meantime since many PECL extensions have been released successfully. Also, uploading functionality has been refactored a bit in the pecl website code recently so in case this still repeats, please report again. Thank you for helping us make PHP better.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 07:01:27 2024 UTC