php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7600 libphp4.so uses old apache API recompile using -DEAPI
Submitted: 2000-11-02 15:18 UTC Modified: 2000-11-03 13:13 UTC
From: ctd at naples dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
43 - 12 = ?
Subscribe to this entry?

 
 [2000-11-02 15:18 UTC] ctd at naples dot net
I run configure as follows:

./configure --with-mysql=/usr2/local/mysql \
 --with-apxs=/usr/sbin/apxs

The build works great! The modules work great too! 

My only problem is when I run "apachectl configtest" I receive the following message:

[Thu Nov  2 14:10:36 2000] [warn] Loaded DSO modules/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
Syntax OK 

The only mention of this issue I can find in readme's or docs is in the NEWS file. Listed March 27,2000 is

- Fixed -DEAPI inheritance from APXS. (Sascha) 

I am sure this is simply ignorance on my part, however I am under pressure to get this last issue corrected.

Thanks for your help
Chris Drever
N.E.T., Inc.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-03 13:13 UTC] sniper@php.net
Please check your Apache build. 
There is nothing wrong with PHP 4.

--Jani
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 04:01:34 2024 UTC