php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75998 ArrayAccess's numeric strings are converted to integers
Submitted: 2018-02-22 19:00 UTC Modified: 2018-02-23 00:11 UTC
From: nospam at nospam dot example dot org Assigned:
Status: Duplicate Package: Arrays related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nospam at nospam dot example dot org
New email:
PHP Version: OS:

 

 [2018-02-22 19:00 UTC] nospam at nospam dot example dot org
Description:
------------
$myArray["345"] = 123; is converted to $myArray->offsetSet(345, 123) but should be $myArray->offsetSet("345", 123)

I tried with strict_types but the result did not change

Thanks you


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-02-23 00:11 UTC] requinix@php.net
-Status: Open +Status: Duplicate -Package: *General Issues +Package: Arrays related
 [2018-02-23 00:11 UTC] requinix@php.net
Duplicate of bug #63217
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 04:01:25 2019 UTC