php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75960 Wrong function to break the reference with the last element
Submitted: 2018-02-14 16:52 UTC Modified: 2018-02-14 16:55 UTC
From: m dot range at mpsn dot de Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: m dot range at mpsn dot de
New email:
PHP Version: OS:

 

 [2018-02-14 16:52 UTC] m dot range at mpsn dot de
Description:
------------
---
From manual page: http://www.php.net/control-structures.foreach
---
Shouldn't the function to break the reference with the last element be "reset" (and not "unset")? It is at least two times on the page.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-02-14 16:55 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-02-14 16:55 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 [2018-02-14 16:55 UTC] requinix@php.net
-Assigned To: cmb +Assigned To:
 [2018-02-14 16:55 UTC] requinix@php.net
No. reset and unset are two completely different things.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 21 10:01:23 2020 UTC