php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75884 efree() used instead of zend_string_free() in socket_recvfrom
Submitted: 2018-01-29 09:37 UTC Modified: 2018-01-29 11:43 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: dktapps at pmmp dot io Assigned: tpunt (profile)
Status: Closed Package: Sockets related
PHP Version: 7.2.1 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dktapps at pmmp dot io
New email:
PHP Version: OS:

 

 [2018-01-29 09:37 UTC] dktapps at pmmp dot io
Description:
------------
efree() is incorrectly used on https://github.com/php/php-src/blob/master/ext/sockets/sockets.c#L1815 . Similar code uses zend_string_free().

This looks like a leftover from PHP 5.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-29 11:15 UTC] tpunt@php.net
-Assigned To: +Assigned To: tpunt
 [2018-01-29 11:43 UTC] tpunt@php.net
-Status: Assigned +Status: Closed
 [2018-01-29 11:43 UTC] tpunt@php.net
Fixed in commit fb128f6512dce083b35a26121a1d685caba16f2e, thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 26 05:05:45 2022 UTC