php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75877 mailing-list subscription web form is broken
Submitted: 2018-01-26 11:54 UTC Modified: 2019-02-04 15:39 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: hajo dot locke at gmx dot de Assigned: heiglandreas (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hajo dot locke at gmx dot de
New email:
PHP Version: OS:

 

 [2018-01-26 11:54 UTC] hajo dot locke at gmx dot de
Description:
------------
Hello,

i just wanted to subscribe to some mailinglists using this form
http://php.net/mailing-lists.php

I subscribed to internals or general list, but i never receive a confirmationmail to finalize subscribe-process.
Some of used Mailadresses work on my own System were iam the mailadmin. I dont see any incoming smtp-connect, so i assume there is a block on sending machine.

Now i did a manual subscription using ezlml in direct way by mailing to internals-subscribe@lists.php.net
This was working, seems to be a website issue.


Test script:
---------------
none

Expected result:
----------------
get confirmationmail.

Actual result:
--------------
no confirmationmail

Patches

75877_phpmailer_composer.patch (last revision 2018-11-12 02:49 UTC by zach at zrhoffman dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-29 07:45 UTC] hajo dot locke at gmx dot de
-Package: Unknown/Other Function +Package: Website problem
 [2018-01-29 07:45 UTC] hajo dot locke at gmx dot de
updated package to "PHP.net Website Problem"
 [2018-02-22 16:47 UTC] carusogabriel34 at gmail dot com
I also experience that, only when I email `internals-subscribe@lists.php.ne` as well. 

Nikita said isn't something new (see https://twitter.com/carusogabriel/status/966128341442007041).
 [2018-02-23 07:50 UTC] Hajo dot Locke at gmx dot de
I dont think it is the same problem.
I also used my personal adresses from servers where iam mailadmin. I could not see any incoming connect from other mailservers to deliver mails. 

Direct Mailing to internals-subscribe@lists.php.net was successful.

From my point of view it looks like website is not triggering mail the right way.
5 Minutes ago i tried it again and i cant see any incoming connect.
If admin is sure that mails are trigered the right way i would like to see this in his maillogs.
 [2018-02-27 22:44 UTC] 93196 dot 93 dot mb at gmail dot com
I can confirm this was an issue when subscribing before Monday. I tried several times over the weekend with no luck. Was entering my email (gmail) after selecting internals and the page would just reload with no confirmation. No email was received either.

On Monday when I tried, I received an email that read like I had sent an email to the list and was asking for confirmation before my message would be posted. Was odd. Replied anyway as instructed and nothing happened, no success reply.

Sent an email to the ezmlm helper as instructed at the bottom of http://php.net/mailing-lists.php ‘php-internals-help@lists.php.net’ also no luck. Here’s how google mail responded:

The response was:
550 php-internals-help@lists.php.net is not a valid address

Also tried php-subscribe-help@lists.php.net which seemed logical but 550 again.

Nikita was spot on with internals-subscribe@lists.php.net. I received an immediate response to my gmail spam folder (no problem), with a response that indicated I had subscribed to the internals list, asking for confirmation which I sent. The response to that was sensible too.

Looks like the instructions on the mail lists page are faulty and perhaps the form is too?
 [2018-02-27 22:48 UTC] 93196 dot 93 dot mb at gmail dot com
Apologies that email should’ve been php-internals-help@lists.php.net
 [2018-09-01 11:09 UTC] cmb@php.net
-Summary: PHP.net Website Problem +Summary: mailing-list subscription web form is broken -Status: Open +Status: Verified
 [2018-09-01 11:09 UTC] cmb@php.net
Note that it is not php-internals*, but rather internals* (i.e. without the PHP prefix).
 [2018-09-01 12:11 UTC] heiglandreas@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: heiglandreas
 [2018-09-01 12:11 UTC] heiglandreas@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

There was a problem with the mailing-list on Monday 27th of August 2018 that got fixed during the following days.

So the issue should be fixed by now. Please try again and report back if it's still broken.

Thanks!
 [2018-09-01 12:59 UTC] cmb@php.net
-Status: Closed +Status: Re-Opened
 [2018-09-01 12:59 UTC] cmb@php.net
This problem has been confirmed only two hours ago:
<https://github.com/php/php-src/pull/3483#issuecomment-417849572>ff.
 [2018-09-04 06:03 UTC] Hajo dot Locke at gmx dot de
Hello,

i tried it again yesterday evening. No confirmationmail on my mailserver, not even a connect to deliver.
Somebody who is willing to solve this should take a serious look.

Thanks,
Hajo
 [2018-11-12 02:50 UTC] zach at zrhoffman dot net
The backend script that php.net mirrors use for subscribing users to mailing lists is https://git.php.net/?p=web/master.git;a=blob;f=entry/subscribe.php;h=7500cc54bb
However, you can make requests to it yourself from the command-line:
`curl 'https://master.php.net/entry/subscribe.php' --data 'request=subscribe&email=your@email.com&maillist=internals&remoteip=1.2.3.4&referer=5.6.7.8'`

There are a few problems with this:
• master.php.net returns silently when you try to subscribe. This would mean that it exits before it can print an error message, so it fails to require PHPMailer files
• php-smtp2.php.net does not resolve, even if using easyDNS's nameservers, and needs to be resolved manually as 72.52.91.12 (according to https://wiki.php.net/systems/php-smtp2)
• After adding php-smtp2.php.net to a local nameserver, php-smtp2.php.net times out when I try to subscribe from a local instance of web/master.git running PHP 5.4 and PHPMailer 6.0.0
• master.php.net runs PHP 5.4, but it is using PHPMailer 6, which requires >=PHP 5.5 (all of the code seems to run fine in PHP 5.4 for this single purpose, however, all the way through PHPMailer 6.0.5)
• If you run `dig php.net mx;` from CLI, it says the MX of php.net is php-smtp3.php.net, which is not listed on https://wiki.php.net/systems, and curiously has a different IPv4 than php-smtp2.php.net but the same IPv6 address
• php-smtp3.php.net times out when I try to subscribe from a local instance of web/master.git

We should make PHPMailer a composer dependency so we can keep track of it (see 75877_phpmailer_composer.patch).
 [2018-11-12 12:16 UTC] cmb@php.net
-Package: Website problem +Package: Systems problem
 [2018-11-12 12:16 UTC] cmb@php.net
Thanks, Zach!  So this is at least partly a systems issue.
 [2019-01-04 06:28 UTC] zach at zrhoffman dot net
Since it is definitely failing before line 13 in https://git.php.net/?p=web/master.git;a=blob;f=entry/subscribe.php;h=350a11d2ac , I should also note that I needed to change line 10 to the following in order for it to run locally:

    include __DIR__ . '/../include/email-validation.inc';

(not necessary if master.php.net's setup has the `include` directory in `include_path`)
 [2019-02-04 08:27 UTC] nikic@php.net
Rasmus has fixed the include path on master.php.net. Browsing directly to missing some parameters now gives the expected "missing some parameters" error. Unfortunately when I try to sign up to a list via php.net there still an error ("We were unable to subscribe you due to some technical problems"), so there's probably more to this.
 [2019-02-04 15:39 UTC] nikic@php.net
-Status: Re-Opened +Status: Closed
 [2019-02-04 15:39 UTC] nikic@php.net
The remaining issue is fixed with https://git.php.net/?p=web/master.git;a=commit;h=5b598f2bab8284240ca756bb9d995d1d2b7e5702. I just verified that the form on php.net now works.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC