php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75814 Documentation not updated to reflect symbol naming rule change in 7.1
Submitted: 2018-01-13 23:25 UTC Modified: 2019-04-17 15:18 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: daverandom@php.net Assigned: girgias (profile)
Status: Closed Package: Variables related
PHP Version: Irrelevant OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daverandom@php.net
New email:
PHP Version: OS:

 

 [2018-01-13 23:25 UTC] daverandom@php.net
Description:
------------
Prior to 7.1, the byte 0x7f was permitted as the first character in a symbol name. Since 7.1, it is no longer allowed. The documentation has not been updated to reflect this.

It needs to be updated on at least this page: http://php.net/manual/en/language.variables.basics.php

There are most likely other places that need to be updated.

Test script:
---------------
https://3v4l.org/UOe2C


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-31 10:28 UTC] vrana@php.net
-Type: Bug +Type: Documentation Problem -Package: Documentation problem +Package: Variables related
 [2018-08-21 02:59 UTC] manabu dot matsui at gmail dot com
These pages also have the same problem.

http://www.php.net/language.constants
http://www.php.net/functions.user-defined
http://www.php.net/language.oop5.basic
 [2019-04-17 15:17 UTC] girgias@php.net
Automatic comment from SVN on behalf of girgias
Revision: http://svn.php.net/viewvc/?view=revision&revision=347269
Log: Updated REGEX of valid symbols in various instances
Fixes Doc Bug #75814
 [2019-04-17 15:18 UTC] girgias@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: girgias
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 09 12:01:24 2019 UTC