php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75793 BC between 7.1.11 and 7.1.13 on router file location.
Submitted: 2018-01-10 14:04 UTC Modified: 2018-01-10 14:20 UTC
From: hello at bweston dot me Assigned: cmb (profile)
Status: Duplicate Package: Built-in web server
PHP Version: 7.1.13 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hello at bweston dot me
New email:
PHP Version: OS:

 

 [2018-01-10 14:04 UTC] hello at bweston dot me
Description:
------------
https://github.com/bweston92/php-7.1-bc-example


Test script:
---------------
The following is <= PHP 7.1.11
```
[bweston@dell serve-test]$ ./test_7_1_11.sh

docker run --rm php@sha256:a92534bf85d3cfe46ed403034e0f0062c9b0867fdf075ca2e34b4bf817902ad0 php --version;
PHP 7.1.11 (cli) (built: Nov  4 2017 10:34:59) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
docker run -d -p 8060:8000 -v $(pwd):/app --workdir /app php@sha256:a92534bf85d3cfe46ed403034e0f0062c9b0867fdf075ca2e34b4bf817902ad0 php -S 0.0.0.0:8000 -t /app/public server.php
fd7c3642c6551094f31e57812d8c36d80e5e816860ba994a5c55dfcc7ca5f63e

curl http://localhost:8060 | head
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "DTD/xhtml1-transitional.dtd">
7<html xmlns="http://www.w3.org/1999/xhtml"><head>
7<style type="text/css">
1body {background-color: #fff; color: #222; font-family: sans-serif;}
8pre {margin: 0; font-family: monospace;}
3 a:link {color: #009; text-decoration: none; background-color: #fff;}
 a:hover {text-decoration: underline;}
 table {border-collapse: collapse; border: 0; width: 934px; box-shadow: 1px 2px 3px #ccc;}
 .center {text-align: center;}
0.center table {margin: 1em auto; text-align: left;}
 77183    0     0  77183      0 --:--:-- --:--:-- --:--:-- 6281k
(23) Failed writing body
```

The following is >= PHP 7.1.13
```
[bweston@dell serve-test]$ ./test_7_1_13.sh

docker run --rm php@sha256:6598b3254f4809005ae03e8a69fe71e667d5615c69a626afb06a176d24044c71 php --version;
PHP 7.1.13 (cli) (built: Jan 10 2018 03:04:36) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
docker run -d -p 8070:8000 -v $(pwd):/app --workdir /app php@sha256:6598b3254f4809005ae03e8a69fe71e667d5615c69a626afb06a176d24044c71 php -S 0.0.0.0:8000 -t /app/public server.php
f047fb74fea077d8b7f54b1c5d084d92f99ae4131d67829d0add42721c893f6d

curl http://localhost:8070 | head
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   288    0   288    0     0    288      0 --:--:-- --:--:-- --:--:-- 36000
<br />
<b>Warning</b>:  Unknown: failed to open stream: No such file or directory in <b>Unknown</b> on line <b>0</b><br />
<br />
<b>Fatal error</b>:  Unknown: Failed opening required '/app/public/server.php' (include_path='.:/usr/local/lib/php') in <b>Unknown</b> on line <b>0</b><br />
```


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-10 14:20 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: *Web Server problem +Package: Built-in web server -Assigned To: +Assigned To: cmb
 [2018-01-10 14:20 UTC] cmb@php.net
That is a duplicate of bug #75604.

Workaround: use the absolute pathname of the router script.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 21:01:24 2020 UTC