php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75739 No note about resource changed to object
Submitted: 2017-12-27 18:59 UTC Modified: 2018-01-28 13:32 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: okopylova at magento dot com Assigned: vrana (profile)
Status: Closed Package: hash (PECL)
PHP Version: 7.2.0 OS: any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: okopylova at magento dot com
New email:
PHP Version: OS:

 

 [2017-12-27 18:59 UTC] okopylova at magento dot com
Description:
------------
---
From manual page: http://www.php.net/function.hash-update
---
Backward incompatible changes for PHP 7.2 (http://php.net/manual/en/migration72.incompatible.php) mention "the Hash extension has been updated to use objects instead of resources". But there is nothing about this in the documentation of the hash functions.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-01 15:08 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2018-01-28 13:32 UTC] vrana@php.net
Automatic comment from SVN on behalf of vrana
Revision: http://svn.php.net/viewvc/?view=revision&revision=344006
Log: Fix #75739: Hash uses objects since PHP 7.2.0
 [2018-01-28 13:32 UTC] vrana@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: vrana
 [2020-02-07 06:05 UTC] phpdocbot@php.net
Automatic comment on behalf of vrana
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=f3e46c7b29574706553f3d892c86aa78ded9e4c0
Log: Fix #75739: Hash uses objects since PHP 7.2.0
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 00:01:24 2020 UTC