php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75646 Logging settings in php.ini ignored
Submitted: 2017-12-07 12:01 UTC Modified: 2018-07-07 17:29 UTC
From: zizzulone at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: IIS related
PHP Version: 5.6.32 OS: WIN 2008R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zizzulone at gmail dot com
New email:
PHP Version: OS:

 

 [2017-12-07 12:01 UTC] zizzulone at gmail dot com
Description:
------------
Win server 2008 R2 , PHP 5.6.31 installaed via web-platform installar in IIS.
php.ini with this setting :
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

but still we have a lot of logging like that in the php log file 
PHP Strict Standards: and PHP Deprecated: 

on the same server with the same php application running (osticket) , with php 5.5.11 we haven't that issue

thank you



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-07 12:15 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2017-12-07 12:15 UTC] requinix@php.net
This is unlikely to be a bug in PHP. Make sure you're editing the correct php.ini (use phpinfo() if you're not sure where it is), that you have not overridden the setting elsewhere (like in code), and that IIS was restarted since making the change.
 [2017-12-07 14:59 UTC] zizzulone at gmail dot com
-Status: Feedback +Status: Open
 [2017-12-07 14:59 UTC] zizzulone at gmail dot com
already done that tests, the ini file is correct , the code is the same that is executed before with 5.5.11, also restarted iis and the server ....
 [2017-12-07 16:06 UTC] zizzulone at gmail dot com
here it is one of the php that logs ...
https://github.com/osTicket/osTicket/blob/develop/include/class.forms.php
 [2018-07-07 17:29 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-07-07 17:29 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Active support for PHP 5.6 ended on 2017-01-19!
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 13:05:52 2023 UTC