php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75613 Wrong spelling and words for number to Indonesian words
Submitted: 2017-12-03 10:02 UTC Modified: 2017-12-04 11:35 UTC
From: yingun at gmail dot com Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 5.6.32 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yingun at gmail dot com
New email:
PHP Version: OS:

 

 [2017-12-03 10:02 UTC] yingun at gmail dot com
Description:
------------
Wrong spelling and wrong word in the output

Test script:
---------------
$f = new NumberFormatter("id", NumberFormatter::SPELLOUT);
echo $f->format(1000000);
//output : satu juts

echo $f->format(1000000000000);
//output : satu bilyun

Expected result:
----------------
$f = new NumberFormatter("id", NumberFormatter::SPELLOUT);
echo $f->format(1000000);
//EXPECTED output : satu juta

echo $f->format(1000000000000);
//EXPECTED output : satu trilyun 

Actual result:
--------------
satu juts
satu bilyun


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-04 11:35 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2017-12-04 11:35 UTC] ab@php.net
Thanks for the report. The output depends on the ICU library linked. PHP 5.6 is delivered with ICU 57.1. With PHP-7.2 which is delivered with ICU 60.1 your expected result shows up. For PHP 5.6, upgrade to a newer ICU is unlikely to happen, i'd recommend you therefore to upgrade to the latest PHP version delivered by php.net.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 11:01:26 2020 UTC