php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7560 strtok or while-loop never returns
Submitted: 2000-10-31 21:35 UTC Modified: 2000-10-31 22:44 UTC
From: lrhazi at netgen dot com Assigned:
Status: Closed Package: Strings related
PHP Version: 4.0.2 OS: Linux 2.2.15-4mdksecurei686
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lrhazi at netgen dot com
New email:
PHP Version: OS:

 

 [2000-10-31 21:35 UTC] lrhazi at netgen dot com
function complete_email_addresses($ilist,$suffix){
	my_info("Entered compelte with [$ilist] and [$suffix]");
	if(($ilist == "")||($suffix == "")){
		my_info("leaving complete too early!");
		return $ilist;
	}
	$name1="";$result="";
	$name = strtok($ilist,",");
	while($name) {
		my_info("inside loop with [$name]");
		$name1 .=$suffix;
		$result .= $name1.",";
	}
	my_info("ilist completed : $result");
	return $result;
	
}

I call this function with ("toto","@domain.com") and it never returns!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-31 22:30 UTC] lrhazi at netgen dot com
You might want to just ignor this, although I d like
to know if you actually would see it as bug...

the problem is that the second call to strtok() is missing
from the body of the while loop!

but the consequence was total hung of my server!
couldnt even get a chance to go to a terminal
or even the console to kill apache or do anything
the only way out is for the client to push the stop
button on his navigator!

Mohamed~

 [2000-10-31 22:44 UTC] joey@php.net
Not a PHP. Look into resource limits.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 09:01:25 2019 UTC