php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75589 RFC3336_EXTENDED format with v
Submitted: 2017-11-29 14:08 UTC Modified: 2017-11-29 14:44 UTC
From: dan dot milligan at psikick dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.6.32 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dan dot milligan at psikick dot com
New email:
PHP Version: OS:

 

 [2017-11-29 14:08 UTC] dan dot milligan at psikick dot com
Description:
------------
---
From manual page: http://www.php.net/class.datetime
---

The format for the RFC3336_EXTENDED is shown as follows:
const string RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;

Should the .v be .u for microseconds?  In practice w/ 5.6.32 on the PI it throws an error w/ a .v

Test script:
---------------
$dateTime = new DateTime();

$dateTime.format("Y-m-d\TH:i:s.vP");




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-29 14:44 UTC] peehaa@php.net
-Status: Open +Status: Not a bug
 [2017-11-29 14:44 UTC] peehaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Specifically the description of the DateTime::RFC3339_EXTENDED constant:

> RFC 3339 EXTENDED format (since PHP 7.0.0) (example: 2005-08-15T15:52:01.000+00:00) 

And the description for the formats on the date docs page: http://php.net/manual/en/function.date.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 04:01:23 2020 UTC