php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75552 php-7.1.12/ext/pcre/pcrelib/pcre_study.c:1372: bad mask ?
Submitted: 2017-11-22 11:27 UTC Modified: 2017-11-22 11:47 UTC
From: dcb314 at hotmail dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 7.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dcb314 at hotmail dot com
New email:
PHP Version: OS:

 

 [2017-11-22 11:27 UTC] dcb314 at hotmail dot com
Description:
------------
php-7.1.12/ext/pcre/pcrelib/pcre_study.c:1372:35: warning: ‘<<’ in boolean context, did you mean ‘<’ ? [-Wint-in-bool-context]

Source code is

     if ((map[c/8] && (1 << (c&7))) != 0)

maybe better code

     if ((map[c/8] & (1 << (c&7))) != 0)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-22 11:47 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: *General Issues +Package: PCRE related -PHP Version: 7.2.0RC6 +PHP Version: 7.1
 [2017-11-22 11:47 UTC] requinix@php.net
Not a PHP bug.

The typo was fixed in PCRE 8.39 (PHP 7.1 uses 8.38) but in their own words it "could not actually affect anything" anyways.

Note that PHP 7.2 uses PCRE 8.41 and PHP 7.3 will bring a switch to PCRE2.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 19:03:36 2022 UTC