php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #75544 Upgrade to last version (current 2015-05-07 3.8.10)
Submitted: 2017-11-20 15:24 UTC Modified: 2017-11-21 11:49 UTC
From: emorrasg at yahoo dot es Assigned: cmb (profile)
Status: Closed Package: SQLite related
PHP Version: 5.6.32 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: emorrasg at yahoo dot es
New email:
PHP Version: OS:

 

 [2017-11-20 15:24 UTC] emorrasg at yahoo dot es
Description:
------------
Current sqlite3 version is 3.8.10 since 2015-05-07, a lot outdated. In windows platform upgrading (at least for me) was unsuccessful.

Documentation says to use VC2012, but link points to nowhere ( “Visual Studio 2012 Express for Windows Desktop” ).

Could you upgrade it ofr next release or compile/publish a new dll? And if you could compile with JSON1, RTREE, FTS5 support (the most used sqlite3 addons), it'll be better.

The nice thing of dlls are that you can upgrade them without disturb the main app that use them.

Thanks


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-11-20 15:28 UTC] spam2 at rhsoft dot net
PHP5 is EOL - there is nothing like a next release except critical security updates - it's time to migrate to 7.0/7.1 when in a few days 7.2 GA is expected and even 7.0 becomes EOL
 [2017-11-20 17:39 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2017-11-20 17:39 UTC] cmb@php.net
It has been decided to not update the bundled libsqlite3 after GA,
unless there are critical issues (such as security related fixes).

You can download VS 2012 from
<https://www.visualstudio.com/de/vs/older-downloads/>; I have just
fixed the link in the Wiki.

With regard to enabling additional extensions, see
<https://github.com/php/php-src/pull/2852>.
 [2017-11-21 09:32 UTC] emorrasg at yahoo dot es
Opps then, didn't know that 5.6 branch is EOL. Upgrading to 7.0 and from it to 7.1. and 7.2

Should I open a new 'Request' for upgrading 7.1 / 7.2 to last sqlite3 version or with the <https://github.com/php/php-src/pull/2852> is enough?

Thanks for the advice.
 [2017-11-21 09:57 UTC] spam2 at rhsoft dot net
https://git.php.net/?p=php-src.git&a=search&h=HEAD&st=commit&s=sqlite
13 days ago 	 Christoph M. Becker	Updated bundled libsqlite to 3.21.0

http://php.net/supported-versions.php
 [2017-11-21 11:49 UTC] cmb@php.net
> Should I open a new 'Request' for upgrading 7.1 / 7.2 to last
> sqlite3 version […]

<https://github.com/php/php-src/pull/2876> has already been
rejected for PHP 7.2.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 06 17:01:26 2021 UTC