php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75293 AI_NUMERICSERV’ undeclared
Submitted: 2017-09-30 00:13 UTC Modified: 2017-09-30 00:50 UTC
From: php-bugs-2017 at ryandesign dot com Assigned:
Status: Closed Package: Sockets related
PHP Version: 7.2.0RC3 OS: Mac OS X 10.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php-bugs-2017 at ryandesign dot com
New email:
PHP Version: OS:

 

 [2017-09-30 00:13 UTC] php-bugs-2017 at ryandesign dot com
Description:
------------
The sockets module from php 7.2.0RC3 (and earlier RCs and betas) fails to build on Mac OS X 10.5 and earlier:


ext/sockets/sockets.c: In function ‘zm_startup_sockets’:
ext/sockets/sockets.c:805: error: ‘AI_NUMERICSERV’ undeclared (first use in this function)


Here's a full build log:

https://build.macports.org/builders/ports-10.5_ppc_legacy-builder/builds/41128/steps/install-port/logs/stdio


The php 7.1.x and earlier versions of the sockets module build fine on the same system.


AI_NUMERICSERV was introduced in Mac OS X 10.6. If you want to use it but remain compatible with older systems, you can apparently define it to 0 if it's not defined:

https://www.mail-archive.com/nbd-general@lists.sourceforge.net/msg01052.html


Note that sapi/phpdbg/phpdbg_io.h already contains these lines:

/* Older versions of glibc <= 2.3.0 and <= OS X 10.5 do not have this constant defined */
#ifndef AI_NUMERICSERV
#define AI_NUMERICSERV 0
#endif

The same lines could be added somewhere for the sockets module.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-30 00:50 UTC] php-bugs-2017 at ryandesign dot com
Sorry, I hit the Submit button twice. Duplicate of #75292.
 [2017-09-30 00:50 UTC] php-bugs-2017 at ryandesign dot com
-Status: Open +Status: Closed
 [2017-09-30 00:50 UTC] php-bugs-2017 at ryandesign dot com
Duplicate
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 15:05:52 2022 UTC