php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #75191 all
Submitted: 2017-09-11 16:48 UTC Modified: 2017-09-11 18:28 UTC
From: dev at null dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Next Major Version OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dev at null dot com
New email:
PHP Version: OS:

 

 [2017-09-11 16:48 UTC] dev at null dot com
Description:
------------
---
From manual page: http://www.php.net/function.http-build-query
---
string http_build_query ( mixed $query_data [, string $numeric_prefix [, string $arg_separator [, int $enc_type = PHP_QUERY_RFC1738 ]]] )

>>>  [,  <<< SHOULD BE : " , [ "

Test script:
---------------
string http_build_query ( mixed $query_data [, string $numeric_prefix [, string $arg_separator [, int $enc_type = PHP_QUERY_RFC1738 ]]] )

>>>  [,  <<< SHOULD BE : " , [ "

Expected result:
----------------
string http_build_query ( mixed $query_data [, string $numeric_prefix [, string $arg_separator [, int $enc_type = PHP_QUERY_RFC1738 ]]] )

>>>  [,  <<< SHOULD BE : " , [ "

Actual result:
--------------
string http_build_query ( mixed $query_data [, string $numeric_prefix [, string $arg_separator [, int $enc_type = PHP_QUERY_RFC1738 ]]] )


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-09-11 16:59 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-09-11 16:59 UTC] requinix@php.net
Not really, no.
 [2017-09-11 18:28 UTC] salathe@php.net
The square bracket pair is a convention used in the PHP manual to denote optional function parameters, as detailed on the "How to read a function definition (prototype)" page [1]. Of note, it is not supposed to be valid PHP syntax.

Thanks for taking the time to file a bug report.

[1] http://php.net/manual/en/about.prototypes.php
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 29 02:01:23 2020 UTC