php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75026 Can not use -9223372036854775808 value on 64bit systems
Submitted: 2017-08-02 16:59 UTC Modified: 2017-08-02 17:05 UTC
From: rwillmann at crooce dot com Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: 7.1.7 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rwillmann at crooce dot com
New email:
PHP Version: OS:

 

 [2017-08-02 16:59 UTC] rwillmann at crooce dot com
Description:
------------
Can not use -9223372036854775808 value on 64bit systems.

Test script:
---------------
print PHP_INT_MIN . "\n";
var_dump(is_int(PHP_INT_MIN));
var_dump(is_int(-9223372036854775808));


Expected result:
----------------
-9223372036854775808
bool(true)
bool(true)

Actual result:
--------------
-9223372036854775808
bool(true)
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-08-02 17:05 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-08-02 17:05 UTC] nikic@php.net
Duplicate of bug #53934.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 17:01:40 2020 UTC