php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75021 Calling 'newPseudoImage' with empty 'caption:' make the fpm process hanging
Submitted: 2017-08-02 08:41 UTC Modified: 2018-12-09 04:22 UTC
From: roman at eyeopen dot nl Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 7.1.7 OS: Ubuntu 16.04
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: roman at eyeopen dot nl
New email:
PHP Version: OS:

 

 [2017-08-02 08:41 UTC] roman at eyeopen dot nl
Description:
------------
The same code snippet (see below) works properly in Ubuntu 14.04, which has Imagick 6.7 installed in it.

Test script:
---------------
$plateWidth = 142;
$plateHeight = 40;
$platePositionX = 434;
$platePositionY = 171;
$fontColor = '#43B19C';
$transparentColor = '#00000000';
$fontPath = 'PUT HERE VALID PATH TO YOUR FONT FILE';

$text = '';

$plate = new Imagick();
$plate->newImage($plateWidth, $plateHeight, new ImagickPixel($transparentColor));
$plate->setBackgroundColor(new ImagickPixel($transparentColor));
$plate->setFont($fontPath);
$plate->setGravity(Imagick::GRAVITY_CENTER);
$plate->newPseudoImage($plateWidth, $plateHeight, "caption:{$text}");

Expected result:
----------------
The empty plate image is rendered.
If the format "caption:" with empty text is not allowed, a clear error message should be shown to the user (developer).

Actual result:
--------------
The php-fpm/apache process hangs, takes longer than 30+2 seconds and eventually crashes because of execution timeout.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-29 03:26 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2018-11-29 03:26 UTC] danack@php.net
Apologies for the slow response.

I'm unable to replicate this issue. I strongly suspect it will be something peculiar to your setup.

If you're able to reproduce the issue with a docker container (or vagrant) box I might be able to investigate, otherwise I can't help.
 [2018-12-09 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 07:03:36 2021 UTC