php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #75 No support for LONG VARCHAR in ODBC/Solid
Submitted: 1998-02-17 07:56 UTC Modified: 1998-02-20 03:31 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: borud at guardian dot no Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 3.0 Latest CVS OS: Linux 2.1.73
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
37 + 29 = ?
Subscribe to this entry?

 
 [1998-02-17 07:56 UTC] borud at guardian dot no
There's no support for LONG VARCHAR in the ODBC/Solid
code, which means you cannot retrieve long text strings
from the database.

This is a highly desirable feature because now people
have to hack their way around it by chopping up
LONG VARCHAR strings with SUBSTR in the SQL query.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-02-20 03:31 UTC] kara
LONG datatype is actually already supported,
but not returned into a PHP variable; they get
send directly to the client. 
Some "read_long" function will be added to
return LONG columns to PHP variables.
 [2014-04-21 21:32 UTC] bwoebi@php.net
Automatic comment on behalf of joe.watkins@live.co.uk
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0b19b9dd0c43484cc141106f2ac7265272c69162
Log: fix #75 phpdbg disabled by default
 [2014-04-21 21:33 UTC] bwoebi@php.net
Automatic comment on behalf of joe.watkins@live.co.uk
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0b19b9dd0c43484cc141106f2ac7265272c69162
Log: fix #75 phpdbg disabled by default
 [2014-04-25 23:25 UTC] ab@php.net
Automatic comment on behalf of joe.watkins@live.co.uk
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0b19b9dd0c43484cc141106f2ac7265272c69162
Log: fix #75 phpdbg disabled by default
 [2014-04-25 23:29 UTC] ab@php.net
Automatic comment on behalf of joe.watkins@live.co.uk
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0b19b9dd0c43484cc141106f2ac7265272c69162
Log: fix #75 phpdbg disabled by default
 [2014-05-01 14:59 UTC] tyrael@php.net
Automatic comment on behalf of joe.watkins@live.co.uk
Revision: http://git.php.net/?p=php-src.git;a=commit;h=0b19b9dd0c43484cc141106f2ac7265272c69162
Log: fix #75 phpdbg disabled by default
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 21:01:28 2024 UTC