php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74945 ZipArchive dont support UTF8 files (names) for open
Submitted: 2017-07-18 11:04 UTC Modified: 2017-07-18 11:14 UTC
From: global dot ninety at gmail dot com Assigned:
Status: Not a bug Package: Zip Related
PHP Version: 5.6.31 OS: Win8/Ubuntu/CentOS
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: global dot ninety at gmail dot com
New email:
PHP Version: OS:

 

 [2017-07-18 11:04 UTC] global dot ninety at gmail dot com
Description:
------------
PHP ZipArchive dont support UTF8 files for open

my problem is OPEN files with UTF8 name. ZipArchive dont open files with UTF8 character. i dont add new file i need only open file.

Test script:
---------------
$path = "files/تست تست.zip";
$zip = new \ZipArchive();
if($zip->open($path) === true) {
   return "File opened";
}
else
{
   return "File could not be opened";
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-18 11:14 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: *General Issues +Package: Zip Related
 [2017-07-18 11:14 UTC] requinix@php.net
@ab already talked about this in your other bug report:
> Thanks for the report. For the Windows part - these issues are fixed in PHP 7.1,
> please also check UPGRADING. On other platforms, it is much a topic of system
> configuration and process locale, not about PHP itself.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 16 09:01:29 2019 UTC