php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74901 Extensions cannot be loaded if PHP is executed in another path
Submitted: 2017-07-11 15:43 UTC Modified: 2017-07-11 15:47 UTC
From: jan dot slabon at setasign dot com Assigned:
Status: Duplicate Package: *Configuration Issues
PHP Version: 7.2.0alpha3 OS: Windows 10 Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jan dot slabon at setasign dot com
New email:
PHP Version: OS:

 

 [2017-07-11 15:43 UTC] jan dot slabon at setasign dot com
Description:
------------
When running php from another path the extensions cannot be loaded in alpha3 if extension_dir is a relative path (extension_dir = "ext"). This works in all versions before.

Test script:
---------------
When calling this in a CMD window:

    C:\Sandbox\tests\php7.2-bug>c:\php\7.2.0alpha3-nts\php test2.php

Several warnings will arise because libraries cannot be loaded.

When calling the script the other way round the extensions are loaded without a problem:

    C:\php\7.2.0alpha3-nts>php c:\Sandbox\tests\php7.2-bug\test2.php



Actual result:
--------------
PHP Warning:  Cannot access dynamic library 'gd2' (tried : ext\gd2, ext\php_gd2.dll) in Unknown on line 0

Warning: Cannot access dynamic library 'gd2' (tried : ext\gd2, ext\php_gd2.dll) in Unknown on line 0
...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-11 15:47 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2017-07-11 15:47 UTC] requinix@php.net
Duplicate of bug #74866.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Jul 19 13:01:25 2018 UTC