php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74897 Links to "warning" & "fatal error" have a blank href
Submitted: 2017-07-11 07:38 UTC Modified: 2020-03-05 08:23 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bug-report@php.net Assigned: cmb (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bug-report@php.net
New email:
PHP Version: OS:

 

 [2017-07-11 07:38 UTC] bug-report@php.net
Description:
------------
This page...

http://php.net/manual/en/function.include.php

...says...

The include construct will emit a warning if it cannot find a file; this is different behavior from require, which will emit a fatal error.

...the links to "warning" & "fatal error" point to the current page, since the href's are blank in the HTML Source...

---\HTML---
  <em>include</em> construct will emit a
  <a href="" class="link">warning</a> if
  it cannot find a file; this is different behavior from
  <span class="function"><a href="function.require.php" class="function">require</a></span>, which will emit a
  <a href="" class="link">fatal error</a>.
 </p>
---/HTML---

Expected result:
----------------
The "warning" link should go to a page about warnings.

The "fatal error" link should go to a page about fatal errors.

Actual result:
--------------
The links to "warning" & "fatal error" point to the same page the links are on, the current page: http://php.net/manual/en/function.include.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-08-29 12:37 UTC] peehaa@php.net
-Status: Open +Status: Verified
 [2017-08-29 12:37 UTC] peehaa@php.net
The same goes on at the docs for the include_path ini setting: http://php.net/manual/en/ini.core.php#ini.include-path
 [2017-08-29 12:37 UTC] peehaa@php.net
-Assigned To: +Assigned To: peehaa
 [2017-10-24 05:17 UTC] kalle@php.net
-Status: Verified +Status: Assigned
 [2018-01-29 23:14 UTC] vrana@php.net
-Type: Documentation Problem +Type: Bug -Package: *General Issues +Package: Doc Build problem
 [2018-01-29 23:14 UTC] vrana@php.net
The links in the sources are correct, this loooks like a PhD problem.
 [2020-03-05 08:17 UTC] cmb@php.net
-Package: Doc Build problem +Package: Documentation problem -Assigned To: peehaa +Assigned To: cmb
 [2020-03-05 08:17 UTC] cmb@php.net
Indeed, this is a limitation of PhD, but given that we usually
just write <constant>E_WARNING</constant> etc., we should do this
in these few cases which try to link directly as well.  If PhD
ever supports automatic linking of constants, then we'd get the
links for free.
 [2020-03-05 08:22 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=349307
Log: Fix #74897: Links to &quot;warning&quot; &amp; &quot;fatal error&quot; have a blank href

Let's be pragmatic, and just use &lt;constant&gt; elements as in the rest of docs,
and hope that PhD will support automatically linking these elements sometime.
 [2020-03-05 08:23 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2020-03-05 08:23 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-03-05 08:30 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=dbf319f8b2d859edf2b1342014c4dbdf6333b81c
Log: Fix #74897: Links to &quot;warning&quot; &amp; &quot;fatal error&quot; have a blank href
 [2020-03-06 02:29 UTC] mumumu@php.net
Automatic comment from SVN on behalf of mumumu
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=349333
Log: Fix #74897: Links to &quot;warning&quot; &amp; &quot;fatal error&quot; have a blank href

Let's be pragmatic, and just use &lt;constant&gt; elements as in the rest of docs,
and hope that PhD will support automatically linking these elements sometime.
 [2020-03-06 04:20 UTC] phpdocbot@php.net
Automatic comment on behalf of mumumu
Revision: http://git.php.net/?p=doc/ja.git;a=commit;h=b99ca4c855797c8d0585265d808346a529f3871e
Log: Fix #74897: Links to &quot;warning&quot; &amp; &quot;fatal error&quot; have a blank href
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Apr 05 19:01:30 2020 UTC