php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74864 MYSQL_ATTR_SSL_VERIFY_SERVER_CERT undefined
Submitted: 2017-07-06 11:49 UTC Modified: 2017-07-06 18:15 UTC
From: andrewjohnmcgrath at gmail dot com Assigned:
Status: Closed Package: PDO MySQL
PHP Version: 7.0.21 OS: ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrewjohnmcgrath at gmail dot com
New email:
PHP Version: OS:

 

 [2017-07-06 11:49 UTC] andrewjohnmcgrath at gmail dot com
Description:
------------
As of this morning when making reference to PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT we encounter an exception:

Undefined class constant 'MYSQL_ATTR_SSL_VERIFY_SERVER_CERT'. I can only assume this was somehow left out of the latest build or the name of this constant has changed [in which case it's an unintended breaking change].

This has caused us to disable SSL over MySQL [hence my classification].



Test script:
---------------
<?php

$options[PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT] = false; //should execute cleanly, but currently does not

Expected result:
----------------
PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT should exist

Actual result:
--------------
Error encountered:

Undefined class constant 'MYSQL_ATTR_SSL_VERIFY_SERVER_CERT'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-06 11:59 UTC] remi@php.net
Can't reproduce

$ php70 -v
PHP 7.0.21 (cli) (built: Jul  5 2017 14:57:12) ( NTS )

$ php70 -r 'var_dump(PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT);'
int(1014)
 [2017-07-06 17:39 UTC] stas@php.net
-Type: Security +Type: Bug
 [2017-07-06 18:15 UTC] andrewjohnmcgrath at gmail dot com
-Status: Open +Status: Closed
 [2017-07-06 18:15 UTC] andrewjohnmcgrath at gmail dot com
Confirmed issue was unrelated and erroneously reported, actual version this was found on was 7.0.2 [which did not support this feature], so there was no actual issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 19:01:44 2019 UTC