php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74846 Master and local ini values are inditical, multiple [PATH] don't work
Submitted: 2017-07-03 09:22 UTC Modified: 2017-07-03 09:39 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: dgagnaire at adequasys dot com Assigned:
Status: Duplicate Package: IIS related
PHP Version: 7.0.20 OS: Windows server 2012 r2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dgagnaire at adequasys dot com
New email:
PHP Version: OS:

 

 [2017-07-03 09:22 UTC] dgagnaire at adequasys dot com
Description:
------------
Hi,

Over windows server 2012, iis and php 7.0.20 fast-cgi (32bit), we usually made php.ini configuration, using [PATH=xx] section to switch global context vars depending on website we are.

Since php 7.0.20 this never works.

Simple test with <?php phpinfo();?> function.

Every time the last [PATH=xx] section is used in master and local value from phpinfo page display.

I think it's really a bug because i downgrade php version with php 7.0.14 release and problem disappear without changing anything else.



Test script:
---------------
<?php phpinfo();?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-07-03 09:26 UTC] spam2 at rhsoft dot net
this is at least the fitfhj identical bugreport to a known problem which is fixed with 7.1.7 / 7.0.21 which are currently in RC state and likely released this thursday
 [2017-07-03 09:33 UTC] dgagnaire at adequasys dot com
thanks i didn't find this problem on the bug report page

regards
 [2017-07-03 09:39 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2017-07-03 09:39 UTC] requinix@php.net
See bug #74738.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC