php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74830 Exceptions thrown by set_error_handler can't always be caught
Submitted: 2017-06-29 15:07 UTC Modified: 2017-12-28 17:23 UTC
From: marco dot marangoni1 at gmail dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 7.1.6 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marco dot marangoni1 at gmail dot com
New email:
PHP Version: OS:

 

 [2017-06-29 15:07 UTC] marco dot marangoni1 at gmail dot com
Description:
------------
As you can see here: https://3v4l.org/BaUji, sometimes an Exception thrown by set_error_handler cannot be caught.

Test script:
---------------
https://3v4l.org/BaUji


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-28 17:23 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-12-28 17:23 UTC] nikic@php.net
Duplicate of bug #53648. Nothing special relating to set_error_handler here, this applies to all exceptions thrown from __toString().
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jun 21 17:01:30 2024 UTC