php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74821 Missing http_cache_etag English Version
Submitted: 2017-06-27 08:57 UTC Modified: 2017-06-30 11:15 UTC
From: jab_creations at yahoo dot com Assigned:
Status: Re-Opened Package: pecl_http (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
40 - 23 = ?
Subscribe to this entry?

 
 [2017-06-27 08:57 UTC] jab_creations at yahoo dot com
Description:
------------
There is no English version for the http_cache_etag function.

Test script:
---------------
http://php.net/manual/en/function.http-cache-etag.php

Expected result:
----------------
Not having to use a translation service.

Actual result:
--------------
Using a translation service.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-27 15:33 UTC] jhdxr@php.net
-Status: Open +Status: Not a bug
 [2017-06-27 15:33 UTC] jhdxr@php.net
the documents for pecl_http have been moved to https://mdref.m6w6.name/http, see https://pecl.php.net/package/pecl_http for more info.
 [2017-06-29 11:19 UTC] jab_creations at yahoo dot com
I'm not sure what any of that means and relative to the priority of everything I'm not going poking around in what was linked.

So this page still exists:
http://php.net/manual/bg/function.http-cache-etag.php

This page still does NOT exist:
http://php.net/manual/en/function.http-cache-etag.php
 [2017-06-29 14:15 UTC] requinix@php.net
-Status: Not a bug +Status: Re-Opened -Package: Website problem +Package: pecl_http
 [2017-06-29 14:15 UTC] requinix@php.net
If the official docs are now offsite then I think we should remove the translated copies from php.net - they're out of date anyways (though probably still reasonably consistent with the OOP update).

Google knows of a few versions, most of which aren't even translated at all:
https://www.google.com/search?q=site%3Aphp.net+http_cache_etag
 [2017-06-30 11:15 UTC] cmb@php.net
The PECL/http related documentation has already been removed from
the manual[1]. Apparently, some old versions have not been removed
from some mirrors.

[1] <http://svn.php.net/viewvc?view=revision&revision=338531>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 08:01:24 2020 UTC