php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74757 PHP on FastCGI / override directives in php.ini files doesn't work anymore
Submitted: 2017-06-14 07:15 UTC Modified: 2017-06-14 07:51 UTC
From: rsmirne at adequasys dot com Assigned:
Status: Duplicate Package: PHP options/info functions
PHP Version: 7.0.20 OS: Windows 2008r2 and 2012r2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rsmirne at adequasys dot com
New email:
PHP Version: OS:

 

 [2017-06-14 07:15 UTC] rsmirne at adequasys dot com
Description:
------------
With PHP 7.0.19, I use directives override in PHP.INI file, per path.

Example :
--------------------------------------
[PATH=D:\vhosts\aaa]
open_basedir=""

[PATH=D:\vhosts\bbb]
open_basedir=""

[PATH=D:\vhosts\xxx]
open_basedir=""
include_path=".;.\includes;.\pear;D:\vhosts\xx\httpdocs;D:\vhosts\xxx\httpdocs\External"

[PATH=D:\vhosts\xxx\simplesamlphp]
open_basedir=""
session.name="xxxrec"

[PATH=D:\vhosts\yyy]
open_basedir=""

[PATH=D:\vhosts\zzzz]
open_basedir=""
extension=php_pdo_sqlsrv_7_nts_x64.dll
extension=php_sqlsrv_7_nts_x64.dll
---------------------------------------------------------


This doesn't work anymore with PHP 7.0.20

Test script:
---------------
You can display phpinfo to see if directive correctly overriden, or not.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-14 07:51 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2017-06-14 07:51 UTC] requinix@php.net
Another duplicate of bug #74738
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 12:01:26 2019 UTC