php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74710 Faulting module name: ODBC32.dll
Submitted: 2017-06-08 13:22 UTC Modified: 2019-09-02 07:15 UTC
Votes:3
Avg. Score:3.3 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:2 (66.7%)
From: dgagnaire at adequasys dot com Assigned: cmb (profile)
Status: Closed Package: pdo_sqlsrv (PECL)
PHP Version: 7.0.23 OS: Windows server 2012 r2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dgagnaire at adequasys dot com
New email:
PHP Version: OS:

 

 [2017-06-08 13:22 UTC] dgagnaire at adequasys dot com
Description:
------------
Hi,

We have a real problematic bug not really depending on php 7 release but from the couple : php7 / pdo_sqlsrv / iis or apache on windows server 2012 r2 (vmware 64 architecture), both x86 or x64 always with vc14 and odbc 13 native driver,  VC14 x86 and x64 are installed


There's no real test suite possible to reproduce but every time the final windows error is as below.

Faulting application name: php-cgi.exe, version: 7.0.20.0, time stamp: 0x5937200f
Faulting module name: ODBC32.dll, version: 6.3.9600.17415, time stamp: 0x545046b6
Exception code: 0xc0000005
Fault offset: 0x000028ee
Faulting process id: 0x1d6c
Faulting application start time: 0x01d2e05700d34720
Faulting application path: C:\PHP\php-cgi.exe
Faulting module path: C:\Windows\SYSTEM32\ODBC32.dll
Report Id: 414fd4b0-4c4a-11e7-80c8-0050568c6901
Faulting package full name: 
Faulting package-relative application ID: 

I try manny solution and the only architecture that works it's :
- php7 ts x86 vc14 as module (from windows.php.net)
- apache 2.4.25 x86 vc14

I lost 3 weeks around a solution but i'm out of patience

The whole wer file is like that :


Version=1
EventType=AutoVerifierV2
EventTime=131414003078255410
ReportType=2
Consent=1
ReportIdentifier=29a0d5b8-4c4a-11e7-80c8-0050568c6901
IntegratorReportIdentifier=29a0d5b7-4c4a-11e7-80c8-0050568c6901
WOW64=1
NsAppName=php-cgi.exe
Response.type=4
Sig[0].Name=Application Name
Sig[0].Value=php-cgi.exe
Sig[1].Name=Application Version
Sig[1].Value=7.0.20.0
Sig[2].Name=Application Timestamp
Sig[2].Value=5937200f
Sig[3].Name=Fault Module Name
Sig[3].Value=ODBC32.dll
Sig[4].Name=Fault Module Version
Sig[4].Value=6.3.9600.17415
Sig[5].Name=Fault Module Timestamp
Sig[5].Value=545046b6
Sig[6].Name=Exception Code
Sig[6].Value=c0000005
Sig[7].Name=Exception Offset
Sig[7].Value=000028ee
Sig[8].Name=Status Code
Sig[8].Value=2
Sig[9].Name=OriginalBucketID
Sig[9].Value=unknown
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=6.3.9600.2.0.0.272.7
DynamicSig[2].Name=Locale ID
DynamicSig[2].Value=4108
DynamicSig[22].Name=Additional Information 1
DynamicSig[22].Value=5861
DynamicSig[23].Name=Additional Information 2
DynamicSig[23].Value=5861822e1919d7c014bbb064c64908b2
DynamicSig[24].Name=Additional Information 3
DynamicSig[24].Value=5f25
DynamicSig[25].Name=Additional Information 4
DynamicSig[25].Value=5f2531ae070278f893fa99352dadd49e
UI[2]=C:\PHP\php-cgi.exe
UI[5]=Check online for a solution (recommended)
UI[6]=Check for a solution later (recommended)
UI[7]=Close
UI[8]=CGI // FastCGI stopped working and was closed
UI[9]=A problem caused the application to stop working correctly. Windows will notify you if a solution is available.
UI[10]=&Close
LoadedModule[0]=C:\PHP\php-cgi.exe
LoadedModule[1]=C:\Windows\SYSTEM32\ntdll.dll
LoadedModule[2]=C:\Windows\syswow64\verifier.dll
LoadedModule[3]=C:\Windows\SYSTEM32\KERNEL32.DLL
LoadedModule[4]=C:\Windows\SYSTEM32\KERNELBASE.dll
LoadedModule[5]=C:\PHP\php7.dll
LoadedModule[6]=C:\Windows\SYSTEM32\WS2_32.dll
LoadedModule[7]=C:\Windows\SYSTEM32\ADVAPI32.dll
LoadedModule[8]=C:\Windows\SYSTEM32\VCRUNTIME140.dll
LoadedModule[9]=C:\Windows\SYSTEM32\api-ms-win-crt-stdio-l1-1-0.dll
LoadedModule[10]=C:\Windows\SYSTEM32\api-ms-win-crt-heap-l1-1-0.dll
LoadedModule[11]=C:\Windows\SYSTEM32\api-ms-win-crt-string-l1-1-0.dll
LoadedModule[12]=C:\Windows\SYSTEM32\api-ms-win-crt-runtime-l1-1-0.dll
LoadedModule[13]=C:\Windows\SYSTEM32\api-ms-win-crt-convert-l1-1-0.dll
LoadedModule[14]=C:\Windows\SYSTEM32\api-ms-win-crt-environment-l1-1-0.dll
LoadedModule[15]=C:\Windows\SYSTEM32\api-ms-win-crt-filesystem-l1-1-0.dll
LoadedModule[16]=C:\Windows\SYSTEM32\api-ms-win-crt-math-l1-1-0.dll
LoadedModule[17]=C:\Windows\SYSTEM32\api-ms-win-crt-locale-l1-1-0.dll
LoadedModule[18]=C:\Windows\SYSTEM32\ole32.dll
LoadedModule[19]=C:\Windows\SYSTEM32\USER32.dll
LoadedModule[20]=C:\Windows\SYSTEM32\DNSAPI.dll
LoadedModule[21]=C:\Windows\SYSTEM32\PSAPI.DLL
LoadedModule[22]=C:\Windows\SYSTEM32\api-ms-win-crt-time-l1-1-0.dll
LoadedModule[23]=C:\Windows\SYSTEM32\api-ms-win-crt-utility-l1-1-0.dll
LoadedModule[24]=C:\Windows\SYSTEM32\NSI.dll
LoadedModule[25]=C:\Windows\SYSTEM32\RPCRT4.dll
LoadedModule[26]=C:\Windows\SYSTEM32\msvcrt.dll
LoadedModule[27]=C:\Windows\SYSTEM32\sechost.dll
LoadedModule[28]=C:\Windows\SYSTEM32\combase.dll
LoadedModule[29]=C:\Windows\SYSTEM32\GDI32.dll
LoadedModule[30]=C:\Windows\SYSTEM32\SspiCli.dll
LoadedModule[31]=C:\Windows\SYSTEM32\ucrtbase.DLL
LoadedModule[32]=C:\Windows\SYSTEM32\CRYPTBASE.dll
LoadedModule[33]=C:\Windows\SYSTEM32\bcryptPrimitives.dll
LoadedModule[34]=C:\PHP\ext\php_pdo_sqlsrv_7_nts_x86.dll
LoadedModule[35]=C:\Windows\SYSTEM32\ODBC32.dll
LoadedModule[36]=C:\Windows\SYSTEM32\MSVCP140.dll
LoadedModule[37]=C:\Windows\SYSTEM32\api-ms-win-crt-multibyte-l1-1-0.dll
LoadedModule[38]=C:\PHP\ext\php_curl.dll
LoadedModule[39]=C:\PHP\libssh2.dll
LoadedModule[40]=C:\PHP\nghttp2.dll
LoadedModule[41]=C:\PHP\LIBEAY32.dll
LoadedModule[42]=C:\PHP\SSLEAY32.dll
LoadedModule[43]=C:\Windows\SYSTEM32\WLDAP32.dll
LoadedModule[44]=C:\Windows\SYSTEM32\Normaliz.dll
LoadedModule[45]=C:\Windows\SYSTEM32\CRYPT32.dll
LoadedModule[46]=C:\Windows\SYSTEM32\api-ms-win-crt-conio-l1-1-0.dll
LoadedModule[47]=C:\Windows\SYSTEM32\MSASN1.dll
LoadedModule[48]=C:\PHP\ext\php_gd2.dll
LoadedModule[49]=C:\PHP\ext\php_bz2.dll
LoadedModule[50]=C:\PHP\ext\php_ldap.dll
LoadedModule[51]=C:\Windows\SYSTEM32\WSOCK32.dll
LoadedModule[52]=C:\PHP\libsasl.dll
LoadedModule[53]=C:\PHP\ext\php_openssl.dll
LoadedModule[54]=C:\PHP\ext\php_pdo_mysql.dll
LoadedModule[55]=C:\PHP\ext\php_xsl.dll
LoadedModule[56]=C:\PHP\ext\php_mbstring.dll
LoadedModule[57]=C:\Windows\SYSTEM32\secur32.dll
LoadedModule[58]=c:\Windows\system32\mswsock.dll
LoadedModule[59]=C:\Windows\SYSTEM32\bcrypt.dll
LoadedModule[60]=C:\Windows\System32\msodbcsql13.dll
LoadedModule[61]=C:\Windows\SYSTEM32\OLEAUT32.dll
LoadedModule[62]=C:\Windows\System32\NETAPI32.dll
LoadedModule[63]=C:\Windows\System32\VERSION.dll
LoadedModule[64]=C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.9600.17810_none_7c5b6194aa0716f1\COMCTL32.dll
LoadedModule[65]=C:\Windows\SYSTEM32\COMDLG32.dll
LoadedModule[66]=C:\Windows\System32\WININET.dll
LoadedModule[67]=C:\Windows\System32\MSVCR120.dll
LoadedModule[68]=C:\Windows\System32\MSVCP120.dll
LoadedModule[69]=C:\Windows\System32\netutils.dll
LoadedModule[70]=C:\Windows\System32\srvcli.dll
LoadedModule[71]=C:\Windows\System32\wkscli.dll
LoadedModule[72]=C:\Windows\SYSTEM32\SHLWAPI.dll
LoadedModule[73]=C:\Windows\SYSTEM32\SHELL32.dll
LoadedModule[74]=C:\Windows\System32\iertutil.dll
LoadedModule[75]=C:\Windows\System32\USERENV.dll
LoadedModule[76]=C:\Windows\System32\profapi.dll
LoadedModule[77]=C:\Windows\System32\SHCORE.DLL
LoadedModule[78]=C:\Windows\SYSTEM32\DPAPI.DLL
LoadedModule[79]=C:\Windows\system32\CLUSAPI.DLL
LoadedModule[80]=C:\Windows\SYSTEM32\cryptdll.dll
LoadedModule[81]=C:\Windows\system32\RESUTILS.DLL
LoadedModule[82]=C:\Windows\SYSTEM32\schannel.dll
LoadedModule[83]=C:\Windows\System32\rasadhlp.dll
LoadedModule[84]=C:\Windows\SYSTEM32\IPHLPAPI.DLL
LoadedModule[85]=C:\Windows\SYSTEM32\WINNSI.DLL
LoadedModule[86]=c:\Windows\System32\fwpuclnt.dll
LoadedModule[87]=C:\Windows\SYSTEM32\ncrypt.dll
LoadedModule[88]=C:\Windows\SYSTEM32\NTASN1.dll
LoadedModule[89]=C:\Windows\system32\ncryptsslp.dll
File[0].CabName=AppCompat.txt
File[0].Path=WERF635.tmp.appcompat.txt
File[0].Flags=16842754
File[0].Type=5
File[0].Original.Path=C:\Windows\Temp\WERF635.tmp.appcompat.txt
File[1].CabName=WERInternalMetadata.xml
File[1].Path=WERF730.tmp.WERInternalMetadata.xml
File[1].Flags=327682
File[1].Type=5
File[1].Original.Path=C:\Windows\Temp\WERF730.tmp.WERInternalMetadata.xml
File[2].CabName=memory.hdmp
File[2].Path=memory.hdmp
File[2].Flags=807403520
File[2].Type=3
File[3].CabName=triagedump.dmp
File[3].Path=triagedump.dmp
File[3].Flags=807731202
File[3].Type=6
FriendlyEventName=Stopped working
ConsentKey=AutoVerifierV2
AppName=CGI // FastCGI
AppPath=C:\PHP\php-cgi.exe
NsPartner=windows
NsGroup=windows8
ApplicationIdentity=43FFBE13D4B197DC2B5ACD75E3FDDA2A



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-12 13:17 UTC] dgagnaire at adequasys dot com
For more information with debugdiag analysis tool and report :

In php-cgi__PID__1572__Date__05_29_2017__Time_12_53_36PM__722__Second_Chance_Exception_C0000005.dmp the assembly instruction at odbc32!FreeStmt+33 in C:\Windows\System32\odbc32.dll from Microsoft Corporation has caused an access violation exception (0xC0000005) when trying to read from memory location 0x38c059b0 on thread 0
 [2017-09-27 12:54 UTC] mohammad dot hikmat at live dot com
Facing the same issue with PHP version 7.1.7 / Apache 2.4.27 / Windows 10 whenever I'm trying to communicate with SQL DB and causing httpd.exe to crash

Event Log:
Faulting application name: httpd.exe, version: 2.4.27.0
Faulting module name: ODBC32.dll, version: 10.0.15063.0
Exception code: 0xc0000005
Fault offset: 0x0003606c
Faulting process id: 0x1110
Faulting application path: C:\xampp\apache\bin\httpd.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ODBC32.dll
 [2017-09-27 14:16 UTC] dgagnaire at adequasys dot com
-PHP Version: 7.0.20 +PHP Version: 7.0.23
 [2017-09-27 14:16 UTC] dgagnaire at adequasys dot com
Hi mohammad,

Please contribute to this issue on github to.

https://github.com/Microsoft/msphpsql/issues/434

Regards
 [2019-09-02 07:15 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-09-02 07:15 UTC] cmb@php.net
> https://github.com/Microsoft/msphpsql/issues/434

Looks like this issue has already been fixed.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 16:01:27 2019 UTC