php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74677 GCC Crash while building.
Submitted: 2017-05-31 00:09 UTC Modified: 2017-05-31 00:51 UTC
From: admin at jordynsblog dot tk Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 7.1.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at jordynsblog dot tk
New email:
PHP Version: OS:

 

 [2017-05-31 00:09 UTC] admin at jordynsblog dot tk
Description:
------------
Building php causes gcc to segfault with this backtrace:

/builddir/php-7.1.5/ext/standard/browscap.c:547:12: internal compiler error: Segmentation fault
 static int browser_reg_compare(
            ^~~~~~~~~~~~~~~~~~~
0x76b7a3df ???
	../sysdeps/unix/sysv/linux/arm/sigrestorer.S:64
0x76b6487b __libc_start_main
	/builddir/glibc-2.25/csu/libc-start.c:295
Please submit a full bug report,
with preprocessed source if appropriate.
Please include the complete backtrace with any bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [Makefile:1974: ext/standard/browscap.lo] Error 1
make: *** Waiting for unfinished jobs....

It only happens if I use parallel jobs with make.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-31 00:11 UTC] admin at jordynsblog dot tk
-: onlinecloud1 at gmail dot com +: admin at jordynsblog dot tk
 [2017-05-31 00:11 UTC] admin at jordynsblog dot tk
Building php causes gcc to segfault with this backtrace:

/builddir/php-7.1.5/ext/standard/browscap.c:547:12: internal compiler error: Segmentation fault
 static int browser_reg_compare(
            ^~~~~~~~~~~~~~~~~~~
0x76b7a3df ???
	../sysdeps/unix/sysv/linux/arm/sigrestorer.S:64
0x76b6487b __libc_start_main
	/builddir/glibc-2.25/csu/libc-start.c:295
Please submit a full bug report,
with preprocessed source if appropriate.
Please include the complete backtrace with any bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [Makefile:1974: ext/standard/browscap.lo] Error 1
make: *** Waiting for unfinished jobs....

It only happens if I use parallel jobs with make.
 [2017-05-31 00:51 UTC] danack@php.net
-Status: Open +Status: Not a bug
 [2017-05-31 00:51 UTC] danack@php.net
Hi,

> Please include the complete backtrace with any bug report.
> See <http://gcc.gnu.org/bugs.html> for instructions.

Included in the link http://gcc.gnu.org/bugs.html is where to submit GCC bug reports https://gcc.gnu.org/bugs/#where - it's at the GCC bug tracker https://gcc.gnu.org/bugzilla/
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jun 03 00:01:27 2020 UTC