php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74518 error /etc/ld.so.cache order
Submitted: 2017-05-01 00:40 UTC Modified: 2017-05-02 11:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: szargv at qq dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.0.18 OS: CentOS 6.9 64Bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: szargv at qq dot com
New email:
PHP Version: OS:

 

 [2017-05-01 00:40 UTC] szargv at qq dot com
Description:
------------
sh# strace php -v
...
open("/usr/pkgs/libmcrypt//lib/tls/x86_64/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/pkgs/libmcrypt//lib/tls/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/pkgs/libmcrypt//lib/x86_64/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/pkgs/libmcrypt//lib/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/pkgs/libpng/lib/tls/x86_64/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)

//so many...
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib64/libcrypt.so.1", O_RDONLY)  = 3


The order maybe: 1,/etc/ld.so.preload 2,/etc/ld.so.cache 3,other 
not: 1,/etc/ld.so.preload 2,other 3,/etc/ld.so.cache

or is my fall?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-05-02 11:00 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2017-05-02 11:00 UTC] ab@php.net
Thanks for the report. The issue has a little to do with PHP. In general, that's a normal lookup process configured on a particular system, but can forcibly pre load teh requiered DSO, if needed. If it's a package, you probably can contact a maintainer. Anyway, once the DSO is found, it's fine, only affects the startup process.

Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 05:05:45 2022 UTC