php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74487 DateInterval inconsistent return values
Submitted: 2017-04-22 07:16 UTC Modified: 2017-04-24 16:24 UTC
From: cristian at sneekdigital dot co dot uk Assigned:
Status: Closed Package: Date/time related
PHP Version: Irrelevant OS: All?
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cristian at sneekdigital dot co dot uk
New email:
PHP Version: OS:

 

 [2017-04-22 07:16 UTC] cristian at sneekdigital dot co dot uk
Description:
------------
When parsing full months (start to end) the return values are inconsistent with some months returning the number of days and some returning one month. The `days` property is always correct however.

We encountered this problem on MacOS and Ubuntu.

Test script:
---------------
https://3v4l.org/GHpCD


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-24 15:53 UTC] heiglandreas@php.net
-Status: Open +Status: Duplicate
 [2017-04-24 15:53 UTC] heiglandreas@php.net
This seems to be a duplicate of https://bugs.php.net/bug.php?id=52480
 [2017-04-24 16:24 UTC] cristian at sneekdigital dot co dot uk
-Status: Duplicate +Status: Closed
 [2017-04-24 16:24 UTC] cristian at sneekdigital dot co dot uk
Please accept my apologies. I would agree.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 04:01:29 2024 UTC