php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74486 stream_socket_client() not works
Submitted: 2017-04-21 12:39 UTC Modified: 2017-04-21 13:19 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mailalexslv at gmail dot com Assigned:
Status: Duplicate Package: Streams related
PHP Version: 7.0.18 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
29 - 6 = ?
Subscribe to this entry?

 
 [2017-04-21 12:39 UTC] mailalexslv at gmail dot com
Description:
------------
PHP 7.0.17
stream_socket_client('tcp://redis-cache.xxxx.amazonaws.com:6379/cache', $errno, $errstr, 5);
return stream resource as expected

PHP 7.0.18
stream_socket_client('tcp://redis-cache.xxxx.amazonaws.com:6379/cache', $errno, $errstr, 5);
return false.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-21 12:46 UTC] spam2 at rhsoft dot net
http://www.catb.org/esr/faqs/smart-questions.html#beprecise

* you don't provide any useful informations
* you hide the hostname
* you don't provide anything showing that you tried ot look for the reason

when you don't do that anybody assumes that the server probably was down or there is some other network issue and since you make it impossible try to reporduce what you are doing - what do you expect?
 [2017-04-21 13:00 UTC] mailalexslv at gmail dot com
Error returned: 'Failed to parse address "redis-cache.xxxx.amazonaws.com:6379/cache" '
 [2017-04-21 13:19 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2017-04-21 13:19 UTC] requinix@php.net
See bug #74429.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 09 08:01:23 2021 UTC