php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74465 Could not found driver for PDO Oci
Submitted: 2017-04-18 08:01 UTC Modified: 2017-04-18 08:23 UTC
From: barbuslex at gmail dot com Assigned:
Status: Not a bug Package: PDO OCI
PHP Version: 7.0.18 OS: Windows Server 2012 R2 64 bits
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: barbuslex at gmail dot com
New email:
PHP Version: OS:

 

 [2017-04-18 08:01 UTC] barbuslex at gmail dot com
Description:
------------
All my php scripts using PDO Oci not working since the update in 7.0.18.

Uncaught Error: Call to undefined function oci_connect() in C:\wwwroot\html\test\inc\bdd.php:28 Stack trace: #0 C:\wwwroot\html\test\inc\common.php(28): require_once() #1 C:\wwwroot\html\test\index.php(2): require_once('C:\\wwwroot\\html...') #2 {main} thrown in C:\wwwroot\html\test\inc\bdd.php on line 28

Cannot connect to database : could not find driver

I have rollback to PHP 7.0.17 : it works perfectly !

I use the same php.ini in both version.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-18 08:06 UTC] barbuslex at gmail dot com
-Status: Open +Status: Closed
 [2017-04-18 08:06 UTC] barbuslex at gmail dot com
Fixed with NTS version
 [2017-04-18 08:23 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 16 23:01:41 2019 UTC