php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74441 Documentation differs from reflection
Submitted: 2017-04-14 14:50 UTC Modified: 2018-01-29 23:25 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: bruce dot ingalls at gmail dot com Assigned:
Status: Not a bug Package: geoip (PECL)
PHP Version: 7.0.18 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bruce dot ingalls at gmail dot com
New email:
PHP Version: OS:

 

 [2017-04-14 14:50 UTC] bruce dot ingalls at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.geoip-country-code-by-name
---
Claims that a $hostname parameter is required, but reflection disagrees

Test script:
---------------
php --rf geoip_country_code_by_name
// No parameters

Expected result:
----------------
I expect reflection to require or allow a parameter,

Actual result:
--------------
Function [ <internal:geoip> function geoip_country_code_by_name ] {
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-01-29 23:25 UTC] vrana@php.net
-Status: Open +Status: Not a bug
 [2018-01-29 23:25 UTC] vrana@php.net
Reflection is wrong. The function fails without the parameter which is what PHP Manual documents.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 22:01:23 2020 UTC