php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74415 This is incorrect $placeholder = substr(str_repeat('?,',count($keys),0,-1));
Submitted: 2017-04-11 13:05 UTC Modified: 2017-04-11 13:19 UTC
From: edcesar at edcesar dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: edcesar at edcesar dot com
New email:
PHP Version: OS:

 

 [2017-04-11 13:05 UTC] edcesar at edcesar dot com
Description:
------------
The example of user Rami jamleh is this:

$placeholder = substr(str_repeat('?,',count($keys),0,-1));

The correct would be:

$place_holders = substr(str_repeat('?,',count($keys)),0,-1);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-11 13:06 UTC] edcesar at edcesar dot com
http://php.net/manual/pt_BR/pdostatement.execute.php
 [2017-04-11 13:15 UTC] bwoebi@php.net
-Type: Bug +Type: Documentation Problem
 [2017-04-11 13:19 UTC] peehaa@php.net
-Status: Open +Status: Not a bug -Type: Documentation Problem +Type: Bug
 [2017-04-11 13:19 UTC] peehaa@php.net
This is not a bug in the official docs, but in the user supplied notes.

I fixed it, but please note that people already commented on the fact that there was a mistake.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 04:01:23 2020 UTC