php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74347 -1 - 0.1 + 1 + 0.1 bugg
Submitted: 2017-03-31 09:17 UTC Modified: 2017-03-31 09:18 UTC
From: stefan at van-echtelt dot nl Assigned:
Status: Not a bug Package: Output Control
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stefan at van-echtelt dot nl
New email:
PHP Version: OS:

 

 [2017-03-31 09:17 UTC] stefan at van-echtelt dot nl
Description:
------------
$test = -1 - 0.1 + 1 + 0.1;
print $test;

if you print this in php the value will be -8.3266726846887E-17.
It should be 0.

Test script:
---------------
$test = -1 - 0.1 + 1 + 0.1;
print $test;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-31 09:18 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-03-31 09:18 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 05:05:52 2022 UTC