php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74328 Syntax error in PHP CLI
Submitted: 2017-03-29 08:03 UTC Modified: 2017-03-29 08:14 UTC
From: namonexarap at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.1.3 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: namonexarap at gmail dot com
New email:
PHP Version: OS:

 

 [2017-03-29 08:03 UTC] namonexarap at gmail dot com
Description:
------------
I have a syntax error when run the following bat-file.
I can't solve this problem.

Test script:
---------------
// The bat-file:
-------------------------------------------------------
@ECHO OFF
cls
echo "echo time();" | START "Console" /B php.exe -a
-------------------------------------------------------

Actual result:
--------------
PHP parse error: syntax error, unexpected end of file in php shell code

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-29 08:14 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-03-29 08:14 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Windows' console does not work the same way that Linux's console does.
Remove the quotes from the echo. Or make use of PHP's -r switch.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 29 01:01:25 2020 UTC