php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74314 does not compile with PHP 7
Submitted: 2017-03-26 02:38 UTC Modified: 2017-03-27 21:29 UTC
From: helmut at evermeet dot cx Assigned: cmb (profile)
Status: Duplicate Package: PDO_IBM (PECL)
PHP Version: 7.1.3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: helmut at evermeet dot cx
New email:
PHP Version: OS:

 

 [2017-03-26 02:38 UTC] helmut at evermeet dot cx
Description:
------------
line 948:

the code should be:

#if PHP_MAJOR_VERSION >= 7
                option_str = Z_STRVAL_P(*data);
#else
                option_str = Z_STRVAL_PP(data);
#endif




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-27 17:43 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2017-03-27 17:43 UTC] cmb@php.net
This is a duplicate of bug #74114.
 [2017-03-27 21:29 UTC] helmut at evermeet dot cx
The other bug was submitted more than a month ago. How long does it take to fix a simple bug? Especially, if you know how to fix it?

Also, the git repository for ibm_db2 was not updated to the latest 1.9.8 and 1.9.9 versions. No commits after June 2015. Really, what are you guys doing?

Maybe IBM should leave the code in hands of people who care for it.
 [2018-06-07 14:54 UTC] ronyan at outlook dot com
See a workaround: pdo_ibm 1.3.5:




#if PHP_MAJOR_VERSION >= 7
                        if (Z_TYPE_P(data) == IS_STRING) {
#else	
			if (Z_TYPE_PP(data) == IS_STRING) {
#endif
//------------- fix ---------------
#if PHP_MAJOR_VERSION >= 7
				option_str = Z_STRVAL_P(data);
#else
				option_str = Z_STRVAL_PP(data);
#endif
//------------- end fix ---------------
		} else {
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 21:01:23 2020 UTC