php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #74299 Going into under the hood of PHP
Submitted: 2017-03-23 14:48 UTC Modified: 2017-03-23 14:51 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: q695 at aol dot com Assigned:
Status: Not a bug Package: PHP Language Specification
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: q695 at aol dot com
New email:
PHP Version: OS:

 

 [2017-03-23 14:48 UTC] q695 at aol dot com
Description:
------------
I've been trying for a while to figure out what code runs a specific part of the language (specifically variable public/private/protected), and was wondering where to find the code that runs the class module since it adds about 10% overhead. Can you please help me figure out what's causing the overhead?

Test script:
---------------
n/a

Expected result:
----------------
a link on the website for something called "under the hood".


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-23 14:51 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-03-23 14:51 UTC] requinix@php.net
Try the internals mailing list. http://php.net/mailing-lists.php
 [2017-03-24 15:58 UTC] q695 at aol dot com
the problem is that the source code documentation is hard to follow internally.
 [2017-03-24 15:58 UTC] q695 at aol dot com
the problem is that the source code documentation is hard to follow internally.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 03:03:36 2021 UTC